Enable -Wnon-virtual-dtor to avoid incorrect C++ code sneaking in
[platform/core/uifw/dali-core.git] / build / tizen / configure.ac
index bebc98a..b379480 100644 (file)
@@ -30,6 +30,9 @@ AC_SUBST(DALI_VERSION)
 
 DALI_CFLAGS=-DPLATFORM_TIZEN
 
+# Use C++ 11
+DALI_CFLAGS="$DALI_CFLAGS -std=c++11 -Wnon-virtual-dtor"
+
 AC_ARG_ENABLE(exportall,
               [AC_HELP_STRING([--enable-exportall],
                               [enables the exporting of all the symbols in the library])],