Enable -Wnon-virtual-dtor to avoid incorrect C++ code sneaking in
[platform/core/uifw/dali-core.git] / build / tizen / configure.ac
index 67d743a..b379480 100644 (file)
@@ -30,6 +30,9 @@ AC_SUBST(DALI_VERSION)
 
 DALI_CFLAGS=-DPLATFORM_TIZEN
 
+# Use C++ 11
+DALI_CFLAGS="$DALI_CFLAGS -std=c++11 -Wnon-virtual-dtor"
+
 AC_ARG_ENABLE(exportall,
               [AC_HELP_STRING([--enable-exportall],
                               [enables the exporting of all the symbols in the library])],
@@ -54,11 +57,19 @@ AC_ARG_ENABLE([backtrace],
               [enable_backtrace=$enableval],
               [enable_backtrace=yes])
 
-AC_ARG_ENABLE([dynamics],
-              [AC_HELP_STRING([--enable-dynamics],
-                              [Builds with dynamics support])],
-              [dynamics_support=$enableval],
-              [dynamics_support=no])
+AC_ARG_ENABLE([lock_backtrace],
+              [AC_HELP_STRING([--enable-lock-backtrace],
+                              [Backtrace for when more than 1 lock is held on the same thread])],
+              [enable_lock_backtrace=$enableval],
+              [enable_lock_backtrace=no])
+
+AC_ARG_ENABLE([gles],
+              [AC_HELP_STRING([--enable-gles],
+                              [Specify the OpenGL ES version for backwards compatibility])],
+              [enable_gles=$enableval],
+              [enable_gles=20])
+
+DALI_CFLAGS="$DALI_CFLAGS -DDALI_GLES_VERSION=${enable_gles}"
 
 if test "x$enable_debug" = "xyes"; then
   DALI_CFLAGS="$DALI_CFLAGS -DDEBUG_ENABLED"
@@ -70,31 +81,22 @@ fi
 
 if test "x$enable_emscripten" = "xyes"; then
   DALI_CFLAGS="$DALI_CFLAGS -DEMSCRIPTEN -std=c++11"
-  # Automatically turn off backtrace support
+  # Automatically turn off backtrace support and mutex locks
   enable_backtrace="no"
+  enable_lock_backtrace="no"
 fi
 
-if test "x$dynamics_support" = "xyes"; then
-  DALI_CFLAGS="$DALI_CFLAGS -DDYNAMICS_SUPPORT"
+# Must come after Emscripten feature test
+if test "x$enable_lock_backtrace" = "xyes"; then
+  DALI_CFLAGS="$DALI_CFLAGS -DLOCK_BACKTRACE_ENABLED"
+  enable_backtrace="yes"
 fi
 
-# Must come after Emscripten feature test
+# Must come after Emscripten & locks backtrace feature test
 if test "x$enable_backtrace" = "xyes"; then
   DALI_CFLAGS="$DALI_CFLAGS -DBACKTRACE_ENABLED"
 fi
 
-AM_CONDITIONAL([DYNAMICS_SUPPORT], [test x$dynamics_support = xyes])
-
-AC_ARG_ENABLE([performance-monitor],
-              [AC_HELP_STRING([--enable-performance-monitor],
-                              [Enables the performance monitor output])],
-              [enable_performance_monitor=$enableval],
-              [enable_performance_monitor=no])
-
-if test "x$enable_performance_monitor" = "xyes"; then
-  DALI_CFLAGS="$DALI_CFLAGS -DPERFORMANCE_MONITOR_ENABLED"
-fi
-
 if test x$DALI_DATA_RW_DIR != x; then
   dataReadWriteDir=$DALI_DATA_RW_DIR
 else
@@ -132,9 +134,9 @@ Configuration
 -------------
   Prefix:                           $prefix
   Debug Build:                      $enable_debug
-  Performance Monitor:              $enable_performance_monitor
   Data Dir (Read/Write):            $dataReadWriteDir
   Data Dir (Read Only):             $dataReadOnlyDir
   Emscripten:                       $enable_emscripten
   Backtrace:                        $enable_backtrace
+  ScopedLock Backtrace:             $enable_lock_backtrace
 "