[Tizen] Add DALi Autofill implementation
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
index 0c73003..dd9a641 100644 (file)
@@ -17,7 +17,7 @@
 
 Name:       dali-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    1.4.29
+Version:    1.4.36
 Release:    1
 Group:      System/Libraries
 License:    Apache-2.0 and BSD-3-Clause and MIT
@@ -65,7 +65,6 @@ BuildRequires:  fribidi-devel
 BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(capi-system-sensor)
 
-BuildRequires:  pkgconfig(libcrypto)
 BuildRequires:  pkgconfig(cairo)
 
 BuildRequires:  pkgconfig(wayland-egl)
@@ -96,6 +95,11 @@ BuildRequires:  pkgconfig(ecore-imf)
 
 BuildRequires:  pkgconfig(capi-system-system-settings)
 
+# for autofill
+%if 0%{?tizen_version_major} >= 5 && 0%{?tizen_version_minor} >= 5
+BuildRequires:  pkgconfig(capi-ui-autofill)
+%endif
+
 # for feedback plugin
 BuildRequires:  pkgconfig(mm-sound)
 BuildRequires:  pkgconfig(feedback)
@@ -283,6 +287,7 @@ TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TI
 %configure --prefix=$PREFIX --with-jpeg-turbo \
            --enable-shaderbincache=DISABLE --enable-profile=MOBILE \
            --enable-tizen-major-version=%{tizen_version_major} \
+           --enable-tizen-minor-version=%{tizen_version_minor} \
            --enable-feedback \
            --enable-efl=no \
 %if 0%{?enable_debug}
@@ -319,6 +324,7 @@ make clean
 %configure --prefix=$PREFIX --with-jpeg-turbo \
            --enable-shaderbincache=DISABLE --enable-profile=TV \
            --enable-tizen-major-version=%{tizen_version_major} \
+           --enable-tizen-minor-version=%{tizen_version_minor} \
            --enable-feedback \
            --enable-efl=no \
 %if 0%{?enable_debug}
@@ -354,6 +360,7 @@ make clean
 %configure --prefix=$PREFIX --with-jpeg-turbo \
            --enable-shaderbincache=DISABLE --enable-profile=WEARABLE \
            --enable-tizen-major-version=%{tizen_version_major} \
+           --enable-tizen-minor-version=%{tizen_version_minor} \
            --enable-feedback \
            --enable-efl=no \
 %if 0%{?enable_debug}
@@ -389,6 +396,7 @@ make clean
 %configure --prefix=$PREFIX --with-jpeg-turbo \
            --enable-shaderbincache=DISABLE --enable-profile=IVI \
            --enable-tizen-major-version=%{tizen_version_major} \
+           --enable-tizen-minor-version=%{tizen_version_minor} \
            --enable-feedback \
            --enable-efl=no \
 %if 0%{?enable_debug}
@@ -426,6 +434,7 @@ make clean
 %configure --prefix=$PREFIX --with-jpeg-turbo \
            --enable-shaderbincache=DISABLE --enable-profile=COMMON \
            --enable-tizen-major-version=%{tizen_version_major} \
+           --enable-tizen-minor-version=%{tizen_version_minor} \
            --enable-feedback \
            --enable-efl=no \
 %if 0%{?enable_debug}