DALi Version 1.3.34
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
index 226f9b8..d34beea 100644 (file)
@@ -19,7 +19,7 @@
 
 Name:       dali-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    1.2.58
+Version:    1.3.34
 Release:    1
 Group:      System/Libraries
 License:    Apache-2.0 and BSD-3-Clause and MIT
@@ -57,6 +57,7 @@ BuildRequires:  pkgconfig(screen_connector_provider)
 
 BuildRequires:  pkgconfig(gles20)
 BuildRequires:  pkgconfig(glesv2)
+BuildRequires:  pkgconfig(ttrace)
 
 %if !0%{?disable_cxx03_build}
 BuildRequires:  dali-devel-cxx03
@@ -84,6 +85,8 @@ BuildRequires:  fribidi-devel
 BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(capi-system-sensor)
 
+BuildRequires:  pkgconfig(libcrypto)
+
 %if %{with wayland}
 
 ####### BUILDING FOR WAYLAND #######
@@ -93,7 +96,11 @@ BuildRequires:  wayland-devel
 BuildRequires:  wayland-extension-client-devel
 
 # dali-adaptor uses ecore mainloop
+%if 0%{?tizen_version_major} >= 5
+BuildRequires:  pkgconfig(ecore-wl2)
+%else
 BuildRequires:  pkgconfig(ecore-wayland)
+%endif
 
 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
 BuildRequires:  pkgconfig(libtbm)
@@ -115,13 +122,13 @@ BuildRequires:  pkgconfig(utilX)
 %endif
 
 # for dali-adaptor
-BuildRequires:  pkgconfig(evas)
-
 %if 0%{?tizen_version_major} == 3
 BuildRequires:  pkgconfig(capi-appfw-application)
 BuildRequires:  pkgconfig(elementary)
 %else
 BuildRequires:  pkgconfig(appcore-ui)
+BuildRequires:  pkgconfig(appcore-widget-base)
+BuildRequires:  pkgconfig(bundle)
 BuildRequires:  pkgconfig(capi-appfw-app-common)
 BuildRequires:  pkgconfig(capi-appfw-app-control)
 BuildRequires:  pkgconfig(ecore-imf)
@@ -135,10 +142,6 @@ BuildRequires:  pkgconfig(mm-sound)
 BuildRequires:  pkgconfig(feedback)
 %endif
 
-# for videoplayer Plugin
-BuildRequires:  pkgconfig(capi-media-player)
-
-
 # for multiprofile
 Requires:   %{name}-compat = %{version}-%{release}
 Recommends: %{name}-profile_common = %{version}-%{release}
@@ -369,18 +372,6 @@ Requires:   %{name} = %{version}-%{release}
 %description dali-feedback-plugin
 Feedback plugin to play haptic and audio feedback for Dali
 
-##############################
-# Dali VideoPlayer Plugin
-##############################
-%if %{with wayland}
-
-%package dali-video-player-plugin
-Summary:    Plugin to play a video file for Dali
-Group:      System/Libraries
-%description dali-video-player-plugin
-VideoPlayer plugin to play a video file for Dali
-%endif
-
 %if !0%{?disable_cxx03_build}
 ##############################
 # Dali Feedback Plugin cxx03
@@ -393,17 +384,6 @@ Requires:   %{name}-cxx03 = %{version}-%{release}
 %description dali-feedback-plugin-cxx03
 Feedback plugin to play haptic and audio feedback for Dali
 
-##############################
-# Dali VideoPlayer Plugin
-##############################
-%if %{with wayland}
-
-%package dali-video-player-plugin-cxx03
-Summary:    Plugin to play a video file for Dali with cxx03 abi
-Group:      System/Libraries
-%description dali-video-player-plugin-cxx03
-VideoPlayer plugin to play a video file for Dali
-%endif
 %endif
 
 ##############################
@@ -440,7 +420,7 @@ VideoPlayer plugin to play a video file for Dali
 %build
 PREFIX+="/usr"
 CXXFLAGS+=" -Wall -g -Os -fPIC -fvisibility-inlines-hidden -fdata-sections -ffunction-sections -DGL_GLEXT_PROTOTYPES"
-LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -Wl,-Bsymbolic-functions "
+LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl,-Bsymbolic-functions "
 
 %ifarch %{arm}
 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
@@ -450,6 +430,18 @@ CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
 CFLAGS+=" -DWAYLAND"
 CXXFLAGS+=" -DWAYLAND"
 configure_flags="--enable-wayland"
+
+# Need Ecore-Wayland2 when Tizen version is 5.x or greater
+%if 0%{?tizen_version_major} >= 5
+CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
+CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
+configure_flags+=" --enable-ecore-wayland2"
+%endif
+%endif
+
+# Use this conditional when Tizen version is 5.x or greater
+%if 0%{?tizen_version_major} >= 5
+CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
 %endif
 
 # Use this conditional when Tizen version is 4.x or greater
@@ -492,7 +484,6 @@ TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TI
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -504,6 +495,9 @@ TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TI
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
+%if 0%{?enable_trace}
+           --enable-trace \
+%endif
            --enable-appfw=yes \
            $configure_flags --libdir=%{_libdir} \
            --enable-rename-so=no
@@ -517,7 +511,7 @@ popd
 
 pushd %{buildroot}%{_libdir}
 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.mobile"; done
-for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done 
+for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
 popd
 
@@ -535,7 +529,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -547,6 +540,9 @@ make clean
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
+%if 0%{?enable_trace}
+           --enable-trace \
+%endif
            --enable-appfw=yes \
            $configure_flags --libdir=%{_libdir} \
            --enable-rename-so=no
@@ -560,7 +556,7 @@ popd
 
 pushd %{buildroot}%{_libdir}
 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.tv"; done
-for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done 
+for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
 popd
 
@@ -577,7 +573,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -589,6 +584,9 @@ make clean
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
+%if 0%{?enable_trace}
+           --enable-trace \
+%endif
            --enable-appfw=yes \
            $configure_flags --libdir=%{_libdir} \
            --enable-rename-so=no
@@ -602,7 +600,7 @@ popd
 
 pushd %{buildroot}%{_libdir}
 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.wearable"; done
-for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done 
+for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
 popd
 
@@ -619,7 +617,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -631,6 +628,9 @@ make clean
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
+%if 0%{?enable_trace}
+           --enable-trace \
+%endif
            --enable-appfw=yes \
            $configure_flags --libdir=%{_libdir} \
            --enable-rename-so=no
@@ -644,7 +644,7 @@ popd
 
 pushd %{buildroot}%{_libdir}
 for FILE in libdali-adaptor*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.ivi"; done
-for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done 
+for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
 
 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
 popd
@@ -653,7 +653,7 @@ make clean
 %endif
 
 #######################################################################
-# common ( build dali_videoplayer_plugin for common uses )
+# common
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if common ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
@@ -663,7 +663,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -675,6 +674,9 @@ make clean
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
+%if 0%{?enable_trace}
+           --enable-trace \
+%endif
            --enable-appfw=yes \
            $configure_flags --libdir=%{_libdir} \
            --enable-rename-so=no
@@ -688,7 +690,7 @@ popd
 
 pushd %{buildroot}%{_libdir}
 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
-for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done 
+for FILE in libdali-*plugin*-cxx11.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
 
 mv pkgconfig/dali-adaptor*pc %{_builddir}/%{name}-%{version}/build/tizen/
 popd
@@ -714,7 +716,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -727,6 +728,9 @@ make clean
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
+%if 0%{?enable_trace}
+           --enable-trace \
+%endif
            --enable-appfw=yes \
            $configure_flags --libdir=%{_libdir} \
            --enable-rename-so=no
@@ -740,7 +744,7 @@ popd
 
 pushd %{buildroot}%{_libdir}
 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.mobile"; done
-for FILE in libdali-*plugin.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done 
+for FILE in libdali-*plugin.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
 popd
 
 make clean
@@ -758,7 +762,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -771,6 +774,9 @@ make clean
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
+%if 0%{?enable_trace}
+           --enable-trace \
+%endif
            --enable-appfw=yes \
            $configure_flags --libdir=%{_libdir} \
            --enable-rename-so=no
@@ -784,7 +790,7 @@ popd
 
 pushd %{buildroot}%{_libdir}
 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.tv"; done
-for FILE in libdali-*plugin.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done 
+for FILE in libdali-*plugin.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
 popd
 
 make clean
@@ -801,7 +807,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -814,6 +819,9 @@ make clean
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
+%if 0%{?enable_trace}
+           --enable-trace \
+%endif
            --enable-appfw=yes \
            $configure_flags --libdir=%{_libdir} \
            --enable-rename-so=no
@@ -827,7 +835,7 @@ popd
 
 pushd %{buildroot}%{_libdir}
 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.wearable"; done
-for FILE in libdali-*plugin.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done 
+for FILE in libdali-*plugin.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
 popd
 
 make clean
@@ -844,7 +852,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -857,6 +864,9 @@ make clean
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
+%if 0%{?enable_trace}
+           --enable-trace \
+%endif
            --enable-appfw=yes \
            $configure_flags --libdir=%{_libdir} \
            --enable-rename-so=no
@@ -870,14 +880,14 @@ popd
 
 pushd %{buildroot}%{_libdir}
 for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.ivi"; done
-for FILE in libdali-*plugin.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done 
+for FILE in libdali-*plugin.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
 popd
 
 make clean
 %endif
 
 #######################################################################
-# common ( build dali_videoplayer_plugin for common uses )
+# common
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if common ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
@@ -888,7 +898,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -901,6 +910,9 @@ make clean
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
+%if 0%{?enable_trace}
+           --enable-trace \
+%endif
            --enable-appfw=yes \
            $configure_flags --libdir=%{_libdir} \
            --enable-rename-so=no
@@ -936,7 +948,7 @@ mv dali-adaptor*.pc %{buildroot}%{_libdir}/pkgconfig/
 popd
 
 ################################################
-#rename 
+#rename
 ###############################################
 pushd %{buildroot}%{_libdir}
 
@@ -1024,19 +1036,6 @@ exit 0
 /sbin/ldconfig
 exit 0
 
-%if %{with wayland}
-%post dali-video-player-plugin
-/sbin/ldconfig
-exit 0
-%endif
-
-%if %{with wayland}
-%postun dali-video-player-plugin
-/sbin/ldconfig
-exit 0
-%endif
-
-
 ##############################
 
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
@@ -1220,14 +1219,6 @@ exit 0
 %exclude %{_libdir}/libdali-adap*.so*.ivi
 #%endif
 
-%if %{with wayland}
-%files dali-video-player-plugin-cxx03
-%manifest dali-adaptor.manifest
-%defattr(-,root,root,-)
-%{_libdir}/libdali-video-player-plugin.so*
-%license LICENSE
-%endif
-
 %if 0%{?tizen_version_major} >= 3
 %files dali-feedback-plugin-cxx03
 %manifest dali-adaptor.manifest
@@ -1239,14 +1230,6 @@ exit 0
 
 #################################################
 
-%if %{with wayland}
-%files dali-video-player-plugin
-%manifest dali-adaptor.manifest
-%defattr(-,root,root,-)
-%{_libdir}/libdali-video-player-plugin-cxx11.so*
-%license LICENSE
-%endif
-
 %if 0%{?tizen_version_major} >= 3
 %files dali-feedback-plugin
 %manifest dali-adaptor.manifest