DALi Version 1.9.13
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
index 93a5897..a295973 100644 (file)
@@ -15,9 +15,9 @@
 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
 %endif
 
-Name:       dali-adaptor
+Name:       dali2-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    1.4.49
+Version:    1.9.13
 Release:    1
 Group:      System/Libraries
 License:    Apache-2.0 and BSD-3-Clause and MIT
@@ -27,9 +27,6 @@ Source0:    %{name}-%{version}.tar.gz
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 Requires:       giflib
-Provides: libdali-adaptor-cxx11.so
-Provides: libdali-adaptor-cxx11.so.0
-Provides: libdali-adaptor-cxx11.so.0.0.0
 
 %define tizen_platform_config_supported 1
 BuildRequires:  pkgconfig(libtzplatform-config)
@@ -46,8 +43,8 @@ BuildRequires:  pkgconfig(gles20)
 BuildRequires:  pkgconfig(glesv2)
 BuildRequires:  pkgconfig(ttrace)
 
-BuildRequires:  dali-devel
-BuildRequires:  dali-integration-devel
+BuildRequires:  dali2-devel
+BuildRequires:  dali2-integration-devel
 
 BuildRequires:  pkgconfig
 BuildRequires:  gawk
@@ -76,7 +73,7 @@ BuildRequires:  pkgconfig(wayland-client)
 BuildRequires:  wayland-devel
 BuildRequires:  wayland-extension-client-devel
 
-# dali-adaptor uses ecore mainloop
+# We use ecore mainloop
 %if 0%{?tizen_version_major} >= 5
 BuildRequires:  pkgconfig(ecore-wl2)
 BuildRequires:  pkgconfig(wayland-egl-tizen)
@@ -84,12 +81,10 @@ BuildRequires:  pkgconfig(wayland-egl-tizen)
 BuildRequires:  pkgconfig(ecore-wayland)
 %endif
 
-# dali-adaptor needs tbm_surface in tizen 3.0 wayland
+# We need tbm_surface in tizen 3.0 wayland
 BuildRequires:  pkgconfig(libtbm)
 
-BuildRequires:  pkgconfig(tpkp-curl)
-
-# for dali-adaptor
+# for the adaptor
 BuildRequires:  pkgconfig(appcore-ui)
 BuildRequires:  pkgconfig(appcore-widget-base)
 BuildRequires:  pkgconfig(bundle)
@@ -125,6 +120,7 @@ Conflicts:      %{name}-profile_tv
 Conflicts:      %{name}-profile_wearable
 Conflicts:      %{name}-profile_ivi
 Conflicts:      %{name}-profile_common
+Requires:       %{name}
 %description profile_mobile
 The DALi Tizen Adaptor for mobile.
 %endif
@@ -139,6 +135,7 @@ Conflicts:      %{name}-profile_mobile
 Conflicts:      %{name}-profile_wearable
 Conflicts:      %{name}-profile_ivi
 Conflicts:      %{name}-profile_common
+Requires:       %{name}
 %description profile_tv
 The DALi Tizen Adaptor for tv.
 %endif
@@ -153,6 +150,7 @@ Conflicts:      %{name}-profile_mobile
 Conflicts:      %{name}-profile_tv
 Conflicts:      %{name}-profile_ivi
 Conflicts:      %{name}-profile_common
+Requires:       %{name}
 %description profile_wearable
 The DALi Tizen Adaptor for wearable.
 %endif
@@ -167,6 +165,7 @@ Conflicts:      %{name}-profile_mobile
 Conflicts:      %{name}-profile_wearable
 Conflicts:      %{name}-profile_tv
 Conflicts:      %{name}-profile_common
+Requires:       %{name}
 %description profile_ivi
 The DALi Tizen Adaptor for ivi.
 %endif
@@ -182,6 +181,7 @@ Conflicts:      %{name}-profile_mobile
 Conflicts:      %{name}-profile_wearable
 Conflicts:      %{name}-profile_tv
 Conflicts:      %{name}-profile_ivi
+Requires:       %{name}
 %description profile_common
 The DALi Tizen Adaptor for common.
 %endif
@@ -212,11 +212,11 @@ Integration development package for the Adaptor - headers for integrating with a
 ##############################
 # Dali Feedback Plugin
 ##############################
-%package dali-feedback-plugin
+%package dali2-feedback-plugin
 Summary:    Plugin to play haptic and audio feedback for Dali
 Group:      System/Libraries
 Requires:   %{name} = %{version}-%{release}
-%description dali-feedback-plugin
+%description dali2-feedback-plugin
 Feedback plugin to play haptic and audio feedback for Dali
 
 ##############################
@@ -271,6 +271,10 @@ cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
 cmake_flags+=" -DENABLE_TRACE=ON"
 %endif
 
+%if 0%{?enable_appfw}
+cmake_flags+=" -DUSE_APPFW"
+%endif
+
 libtoolize --force
 cd %{_builddir}/%{name}-%{version}/build/tizen
 
@@ -385,10 +389,10 @@ pushd %{_builddir}/%{name}-%{version}/build/tizen
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
 pushd mobile
 %make_install
+%if "%{?profile}" != "mobile"
 pushd  %{buildroot}%{_libdir}
-cp libdali-adaptor.so.*.*.* libdali-adaptor.so.mobile
+cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.mobile # If we're only building this profile, then there's no need to copy the lib
 popd
-%if "%{?profile}" != "mobile"
 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
 %endif
 popd
@@ -398,10 +402,10 @@ popd
 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
 pushd tv
 %make_install
+%if "%{?profile}" != "tv"
 pushd  %{buildroot}%{_libdir}
-cp libdali-adaptor.so.*.*.* libdali-adaptor.so.tv
+cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.tv # If we're only building this profile, then there's no need to copy the lib
 popd
-%if "%{?profile}" != "tv"
 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
 %endif
 popd
@@ -411,10 +415,10 @@ popd
 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
 pushd wearable
 %make_install
+%if "%{?profile}" != "wearable"
 pushd  %{buildroot}%{_libdir}
-cp libdali-adaptor.so.*.*.* libdali-adaptor.so.wearable
+cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.wearable # If we're only building this profile, then there's no need to copy the lib
 popd
-%if "%{?profile}" != "wearable"
 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
 %endif
 popd
@@ -424,10 +428,10 @@ popd
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
 pushd ivi
 %make_install
+%if "%{?profile}" != "ivi"
 pushd  %{buildroot}%{_libdir}
-cp libdali-adaptor.so.*.*.* libdali-adaptor.so.ivi
+cp libdali2-adaptor.so.*.*.* libdali2-adaptor.so.ivi # If we're only building this profile, then there's no need to copy the lib
 popd
-%if "%{?profile}" != "ivi"
 make clean # So that we can gather symbol/size information for only one profile if we're building all profiles
 %endif
 popd
@@ -441,13 +445,6 @@ pushd common
 popd
 %endif
 
-# Create links to ensure linking with cxx11 library is preserved
-pushd  %{buildroot}%{_libdir}
-ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so
-ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so.0
-ln -sf libdali-adaptor.so libdali-adaptor-cxx11.so.0.0.0
-popd
-
 # Create a symbolic link in integration-api to preserve legacy repo build
 pushd %{buildroot}%{_includedir}/dali/integration-api
 ln -sf adaptor-framework adaptors
@@ -470,7 +467,7 @@ exit 0
 
 %post
 pushd %{_libdir}
-for i in mobile tv wearable ivi; do [[ -f libdali-adaptor.so.$i ]] && ln -sf libdali-adaptor.so.$i libdali-adaptor.so.0.0.0; done
+for i in mobile tv wearable ivi; do [[ -f libdali2-adaptor.so.$i ]] && ln -sf libdali2-adaptor.so.$i libdali2-adaptor.so.2.0.0; done
 popd
 /sbin/ldconfig
 exit 0
@@ -485,11 +482,14 @@ exit 0
 ##############################
 # Mobile Profile Commands
 # if mobile || "undefined"
+# No need to create a symbolic link on install required if only building this profile
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
 %post profile_mobile
+%if "%{?profile}" != "mobile"
 pushd %{_libdir}
-ln -sf libdali-adaptor.so.mobile libdali-adaptor.so.0.0.0
+ln -sf libdali2-adaptor.so.mobile libdali2-adaptor.so.2.0.0
 popd
+%endif
 /sbin/ldconfig
 exit 0
 
@@ -500,11 +500,14 @@ exit 0
 
 ##############################
 # TV Profile Commands
+# No need to create a symbolic link on install required if only building this profile
 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
 %post profile_tv
+%if "%{?profile}" != "tv"
 pushd %{_libdir}
-ln -sf libdali-adaptor.so.tv libdali-adaptor.so.0.0.0
+ln -sf libdali2-adaptor.so.tv libdali2-adaptor.so.2.0.0
 popd
+%endif
 /sbin/ldconfig
 exit 0
 
@@ -515,11 +518,14 @@ exit 0
 
 ##############################
 # Wearable Profile Commands
+# No need to create a symbolic link on install required if only building this profile
 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
 %post profile_wearable
+%if "%{?profile}" != "wearable"
 pushd %{_libdir}
-ln -sf libdali-adaptor.so.wearable libdali-adaptor.so.0.0.0
+ln -sf libdali2-adaptor.so.wearable libdali2-adaptor.so.2.0.0
 popd
+%endif
 /sbin/ldconfig
 exit 0
 
@@ -530,11 +536,14 @@ exit 0
 
 ##############################
 # IVI Profile Commands
+# No need to create a symbolic link on install required if only building this profile
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
 %post profile_ivi
+%if "%{?profile}" != "ivi"
 pushd %{_libdir}
-ln -sf libdali-adaptor.so.ivi libdali-adaptor.so.0.0.0
+ln -sf libdali2-adaptor.so.ivi libdali2-adaptor.so.0.0.0
 popd
+%endif
 /sbin/ldconfig
 exit 0
 
@@ -566,19 +575,16 @@ exit 0
 %{_bindir}/*
 %license LICENSE
 %defattr(-,root,root,-)
-%{_libdir}/libdali-adaptor-cxx11.so
-%{_libdir}/libdali-adaptor-cxx11.so.0
-%{_libdir}/libdali-adaptor-cxx11.so.0.0.0
-%{_libdir}/libdali-adaptor.so
-%{_libdir}/libdali-adaptor.so.0
-%{_libdir}/libdali-adaptor.so.0.0.0
+%{_libdir}/libdali2-adaptor.so
+%{_libdir}/libdali2-adaptor.so.2
+%{_libdir}/libdali2-adaptor.so.2.0.0
 
 #################################################
 
-%files dali-feedback-plugin
+%files dali2-feedback-plugin
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
-%{_libdir}/libdali-feedback-plugin-cxx11.so*
+%{_libdir}/libdali2-feedback-plugin.so*
 %{dali_plugin_sound_files}/*
 
 #################################################
@@ -595,7 +601,9 @@ exit 0
 %files profile_mobile
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
-%{_libdir}/libdali-adaptor.so.mobile
+%if "%{?profile}" != "mobile"
+%{_libdir}/libdali2-adaptor.so.mobile
+%endif
 %endif
 
 # if tv ||"undefined"
@@ -603,7 +611,9 @@ exit 0
 %files profile_tv
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
-%{_libdir}/libdali-adaptor.so.tv
+%if "%{?profile}" != "tv"
+%{_libdir}/libdali2-adaptor.so.tv
+%endif
 %endif
 
 # if wearable || "undefined"
@@ -611,7 +621,9 @@ exit 0
 %files profile_wearable
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
-%{_libdir}/libdali-adaptor.so.wearable
+%if "%{?profile}" != "wearable"
+%{_libdir}/libdali2-adaptor.so.wearable
+%endif
 %endif
 
 # if ivi ||"undefined"
@@ -619,7 +631,9 @@ exit 0
 %files profile_ivi
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
-%{_libdir}/libdali-adaptor.so.ivi
+%if "%{?profile}" != "ivi"
+%{_libdir}/libdali2-adaptor.so.ivi
+%endif
 %endif
 
 %files devel
@@ -628,10 +642,10 @@ exit 0
 %{_includedir}/dali/public-api/*
 %{_includedir}/dali/devel-api/*
 %{_includedir}/dali/doc/*
-%{_libdir}/pkgconfig/dali-adaptor.pc
+%{_libdir}/pkgconfig/dali2-adaptor.pc
 
 %files integration-devel
 %defattr(-,root,root,-)
 %{_includedir}/dali/integration-api/adaptor-framework/*
 %{_includedir}/dali/integration-api/adaptors
-%{_libdir}/pkgconfig/dali-adaptor-integration.pc
+%{_libdir}/pkgconfig/dali2-adaptor-integration.pc