DALi Version 1.4.25
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
index 6a9a927..465c29f 100644 (file)
 %global __provides_exclude_from ^.*\\.(wearable|mobile|tv|ivi|common)$
 %endif
 
-%bcond_with wayland
-
 Name:       dali-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    1.3.49
+Version:    1.4.25
 Release:    1
 Group:      System/Libraries
 License:    Apache-2.0 and BSD-3-Clause and MIT
@@ -30,22 +28,8 @@ Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 Requires:       giflib
 
-#need libtzplatform-config for directory if tizen version is 3.x
-
-%if 0%{?tizen_version_major} >= 3
 %define tizen_platform_config_supported 1
 BuildRequires:  pkgconfig(libtzplatform-config)
-%endif
-
-%if 0%{?tizen_version_major} < 4
-%define disable_cxx03_build 1
-%endif
-
-# Get the profile from tizen_profile_name if tizen version is 2.x and tizen_profile_name exists.
-
-%if "%{tizen_version_major}" == "2" && 0%{?tizen_profile_name:1}
-%define profile %{tizen_profile_name}
-%endif
 
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if wearable || "undefined"
@@ -59,10 +43,6 @@ BuildRequires:  pkgconfig(gles20)
 BuildRequires:  pkgconfig(glesv2)
 BuildRequires:  pkgconfig(ttrace)
 
-%if !0%{?disable_cxx03_build}
-BuildRequires:  dali-devel-cxx03
-BuildRequires:  dali-integration-devel-cxx03
-%endif
 BuildRequires:  dali-devel
 BuildRequires:  dali-integration-devel
 
@@ -86,10 +66,8 @@ BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(capi-system-sensor)
 
 BuildRequires:  pkgconfig(libcrypto)
+BuildRequires:  pkgconfig(cairo)
 
-%if %{with wayland}
-
-####### BUILDING FOR WAYLAND #######
 BuildRequires:  pkgconfig(wayland-egl)
 BuildRequires:  pkgconfig(wayland-client)
 BuildRequires:  wayland-devel
@@ -106,42 +84,21 @@ BuildRequires:  pkgconfig(ecore-wayland)
 # dali-adaptor needs tbm_surface in tizen 3.0 wayland
 BuildRequires:  pkgconfig(libtbm)
 
-# tpkp-curl (certificate pinning for libcurl functions) is only available in Tizen 3.0
-%if !0%{?disable_cxx03_build}
-BuildRequires:  pkgconfig(tpkp-curl-deprecated)
-%endif
 BuildRequires:  pkgconfig(tpkp-curl)
 
-####### BUILDING FOR X11#######
-%else
-BuildRequires:  pkgconfig(egl)
-BuildRequires:  pkgconfig(xext)
-BuildRequires:  pkgconfig(xi)
-BuildRequires:  pkgconfig(xfixes)
-BuildRequires:  pkgconfig(xdamage)
-BuildRequires:  pkgconfig(utilX)
-%endif
-
 # for dali-adaptor
-%if 0%{?tizen_version_major} == 3
-BuildRequires:  pkgconfig(capi-appfw-application)
-BuildRequires:  pkgconfig(elementary)
-%else
 BuildRequires:  pkgconfig(appcore-ui)
 BuildRequires:  pkgconfig(appcore-widget-base)
 BuildRequires:  pkgconfig(bundle)
 BuildRequires:  pkgconfig(capi-appfw-app-common)
 BuildRequires:  pkgconfig(capi-appfw-app-control)
 BuildRequires:  pkgconfig(ecore-imf)
-%endif
 
 BuildRequires:  pkgconfig(capi-system-system-settings)
 
 # for feedback plugin
 BuildRequires:  pkgconfig(mm-sound)
-%if 0%{?tizen_version_major} >= 3
 BuildRequires:  pkgconfig(feedback)
-%endif
 
 # for multiprofile
 Requires:   %{name}-compat = %{version}-%{release}
@@ -151,16 +108,6 @@ Recommends: %{name}-profile_common = %{version}-%{release}
 The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
 platform abstraction and application shell
 
-%if !0%{?disable_cxx03_build}
-%package cxx03
-Summary:       The DALi Tizen Adaptor with cxx03 abi
-Provides:      %{name}-cxx03 = %{version}-%{release}
-
-%description cxx03
-The DALi Tizen Adaptor provides a Tizen specific implementation of the dali-core
-platform abstraction and application shell
-%endif
-
 ###########################################
 # Dali adapter for profiles
 ###########################################
@@ -226,7 +173,6 @@ The DALi Tizen Adaptor for ivi.
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
 # Currently Tizen Common we use does not have wayland extensions like xdg-shell
 %package profile_common
-%define tizen_2_2_compatibility 0
 Summary:        The DALi Tizen Adaptor for common
 Provides:       %{name}-compat = %{version}-%{release}
 Conflicts:      %{name}-profile_mobile
@@ -237,84 +183,6 @@ Conflicts:      %{name}-profile_ivi
 The DALi Tizen Adaptor for common.
 %endif
 
-%if !0%{?disable_cxx03_build}
-###########################################
-# Dali adapter for profiles for cxx03 ABI
-###########################################
-
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if mobile || "undefined"
-%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
-%package profile_mobile-cxx03
-Summary:       The DALi Tizen Adaptor for mobile with cxx03 abi
-Provides:      %{name}-cxx03-compat = %{version}-%{release}
-Conflicts:     %{name}-profile_tv-cxx03
-Conflicts:     %{name}-profile_wearable-cxx03
-Conflicts:     %{name}-profile_ivi-cxx03
-Conflicts:     %{name}-profile_common-cxx03
-%description profile_mobile-cxx03
-The DALi Tizen Adaptor for mobile.
-%endif
-
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if tv ||"undefined"
-%if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
-%package profile_tv-cxx03
-Summary:       The DALi Tizen Adaptor for tv with cxx03 abi
-Provides:      %{name}-cxx03-compat = %{version}-%{release}
-Conflicts:     %{name}-profile_mobile-cxx03
-Conflicts:     %{name}-profile_wearable-cxx03
-Conflicts:     %{name}-profile_ivi-cxx03
-Conflicts:     %{name}-profile_common-cxx03
-%description profile_tv-cxx03
-The DALi Tizen Adaptor for tv.
-%endif
-
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if wearable || "undefined"
-%if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
-%package profile_wearable-cxx03
-Summary:       The DALi Tizen Adaptor for wearable with cxx03 abi
-Provides:      %{name}-cxx03-compat = %{version}-%{release}
-Conflicts:     %{name}-profile_mobile-cxx03
-Conflicts:     %{name}-profile_tv-cxx03
-Conflicts:     %{name}-profile_ivi-cxx03
-Conflicts:     %{name}-profile_common-cxx03
-%description profile_wearable-cxx03
-The DALi Tizen Adaptor for wearable.
-%endif
-
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if ivi ||"undefined"
-%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
-%package profile_ivi-cxx03
-Summary:       The DALi Tizen Adaptor for ivi with cxx03 abi
-Provides:      %{name}-cxx03-compat = %{version}-%{release}
-Conflicts:     %{name}-profile_mobile-cxx03
-Conflicts:     %{name}-profile_wearable-cxx03
-Conflicts:     %{name}-profile_tv-cxx03
-Conflicts:     %{name}-profile_common-cxx03
-%description profile_ivi-cxx03
-The DALi Tizen Adaptor for ivi.
-%endif
-
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if common ||"undefined"
-%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
-# Currently Tizen Common we use does not have wayland extensions like xdg-shell
-%package profile_common-cxx03
-%define tizen_2_2_compatibility 0
-Summary:  The DALi Tizen Adaptor for common with cxx03 abi
-Provides:      %{name}-cxx03-compat = %{version}-%{release}
-Conflicts:     %{name}-profile_mobile-cxx03
-Conflicts:     %{name}-profile_wearable-cxx03
-Conflicts:     %{name}-profile_tv-cxx03
-Conflicts:     %{name}-profile_ivi-cxx03
-%description profile_common-cxx03
-The DALi Tizen Adaptor for common.
-%endif
-%endif
-
 ##############################
 # devel
 ##############################
@@ -338,31 +206,6 @@ Requires:   %{name} = %{version}-%{release}
 %description integration-devel
 Integration development package for the Adaptor - headers for integrating with an adaptor library.
 
-%if !0%{?disable_cxx03_build}
-##############################
-# devel cxx03
-##############################
-%package devel-cxx03
-Summary:    Development components for the DALi Tizen Adaptor with cxx03 abi
-Group:      Development/Building
-Requires:   %{name}-cxx03 = %{version}-%{release}
-Requires:   %{name}-integration-devel-cxx03 = %{version}-%{release}
-
-%description devel-cxx03
-Development components for the DALi Tizen Adaptor - public headers and package configs
-
-##############################
-# integration-devel cxx03
-##############################
-%package integration-devel-cxx03
-Summary:    Integration development package for the Adaptor with cxx03 abi
-Group:      Development/Building
-Requires:   %{name}-cxx03 = %{version}-%{release}
-
-%description integration-devel-cxx03
-Integration development package for the Adaptor - headers for integrating with an adaptor library.
-%endif
-
 ##############################
 # Dali Feedback Plugin
 ##############################
@@ -373,20 +216,6 @@ Requires:   %{name} = %{version}-%{release}
 %description dali-feedback-plugin
 Feedback plugin to play haptic and audio feedback for Dali
 
-%if !0%{?disable_cxx03_build}
-##############################
-# Dali Feedback Plugin cxx03
-##############################
-
-%package dali-feedback-plugin-cxx03
-Summary:    Plugin to play haptic and audio feedback for Dali with cxx03 abi
-Group:      System/Libraries
-Requires:   %{name}-cxx03 = %{version}-%{release}
-%description dali-feedback-plugin-cxx03
-Feedback plugin to play haptic and audio feedback for Dali
-
-%endif
-
 ##############################
 # Preparation
 ##############################
@@ -395,21 +224,12 @@ Feedback plugin to play haptic and audio feedback for Dali
 
 #Use TZ_PATH when tizen version is 3.x or greater
 
-%if 0%{?tizen_version_major} >= 3
 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
 %define font_downloaded_path     %TZ_SYS_SHARE/fonts/
 %define font_application_path    %TZ_SYS_RO_SHARE/app_fonts/
 %define font_configuration_file  %TZ_SYS_ETC/fonts/conf.avail/99-slp.conf
-%else
-%define dali_data_rw_dir         /usr/share/dali/
-%define dali_data_ro_dir         /usr/share/dali/
-%define font_preloaded_path      /usr/share/fonts/
-%define font_downloaded_path     /opt/share/fonts/
-%define font_application_path    /usr/share/app_fonts/
-%define font_configuration_file  /opt/etc/fonts/conf.avail/99-slp.conf
-%endif
 
 %define user_shader_cache_dir    %{dali_data_ro_dir}/core/shaderbin/
 %define dali_plugin_sound_files  /plugins/sounds/
@@ -427,32 +247,18 @@ LDFLAGS+=" -Wl,--rpath=%{_libdir} -Wl,--as-needed -Wl,--gc-sections -lttrace -Wl
 CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
 %endif
 
-%if %{with wayland}
 CFLAGS+=" -DWAYLAND"
 CXXFLAGS+=" -DWAYLAND"
 configure_flags="--enable-wayland"
 
-# Need Ecore-Wayland2 when Tizen version is 5.x or greater
-%if 0%{?tizen_version_major} >= 5
-CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
-CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
-configure_flags+=" --enable-ecore-wayland2"
-%endif
-%endif
-
 # Use this conditional when Tizen version is 5.x or greater
 %if 0%{?tizen_version_major} >= 5
 CXXFLAGS+=" -DOVER_TIZEN_VERSION_5"
-%endif
-
-# Use this conditional when Tizen version is 4.x or greater
-%if 0%{?tizen_version_major} >= 4
-CXXFLAGS+=" -DOVER_TIZEN_VERSION_4"
-%endif
 
-%if 0%{?tizen_2_2_compatibility}
-CFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
-CXXFLAGS+=" -DTIZEN_SDK_2_2_COMPATIBILITY"
+# Need Ecore-Wayland2 when Tizen version is 5.x or greater
+CFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
+CXXFLAGS+=" -DECORE_WAYLAND2 -DEFL_BETA_API_SUPPORT"
+configure_flags+=" --enable-ecore-wayland2"
 %endif
 
 libtoolize --force
@@ -469,30 +275,16 @@ FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION
 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
 %endif
 
-# Default to GLES 2.0 if not specified.
-%if 0%{?target_gles_version} == 0
-%define target_gles_version 20
-%endif
-
 # Set up the build via configure.
 #######################################################################
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if mobile || "undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
-%configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
+%configure --prefix=$PREFIX --with-jpeg-turbo \
            --enable-shaderbincache=DISABLE --enable-profile=MOBILE \
            --enable-tizen-major-version=%{tizen_version_major} \
-%if 0%{?tizen_version_major} >= 3
            --enable-feedback \
-%endif
-%if 0%{?tizen_2_2_compatibility}
-           --with-tizen-2-2-compatibility \
-%endif
-%if %{with wayland}
            --enable-efl=no \
-%else
-           --enable-efl=yes \
-%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -524,20 +316,11 @@ make clean
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if tv ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
-%configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
+%configure --prefix=$PREFIX --with-jpeg-turbo \
            --enable-shaderbincache=DISABLE --enable-profile=TV \
            --enable-tizen-major-version=%{tizen_version_major} \
-%if 0%{?tizen_version_major} >= 3
            --enable-feedback \
-%endif
-%if 0%{?tizen_2_2_compatibility}
-           --with-tizen-2-2-compatibility \
-%endif
-%if %{with wayland}
            --enable-efl=no \
-%else
-           --enable-efl=yes \
-%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -568,20 +351,11 @@ make clean
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if wearable || "undefined"
 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
-%configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
+%configure --prefix=$PREFIX --with-jpeg-turbo \
            --enable-shaderbincache=DISABLE --enable-profile=WEARABLE \
            --enable-tizen-major-version=%{tizen_version_major} \
-%if 0%{?tizen_version_major} >= 3
            --enable-feedback \
-%endif
-%if 0%{?tizen_2_2_compatibility}
-           --with-tizen-2-2-compatibility \
-%endif
-%if %{with wayland}
            --enable-efl=no \
-%else
-           --enable-efl=yes \
-%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -612,20 +386,11 @@ make clean
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if ivi ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
-%configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
+%configure --prefix=$PREFIX --with-jpeg-turbo \
            --enable-shaderbincache=DISABLE --enable-profile=IVI \
            --enable-tizen-major-version=%{tizen_version_major} \
-%if 0%{?tizen_version_major} >= 3
            --enable-feedback \
-%endif
-%if 0%{?tizen_2_2_compatibility}
-           --with-tizen-2-2-compatibility \
-%endif
-%if %{with wayland}
            --enable-efl=no \
-%else
-           --enable-efl=yes \
-%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -658,20 +423,11 @@ make clean
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if common ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
-%configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
+%configure --prefix=$PREFIX --with-jpeg-turbo \
            --enable-shaderbincache=DISABLE --enable-profile=COMMON \
            --enable-tizen-major-version=%{tizen_version_major} \
-%if 0%{?tizen_version_major} >= 3
            --enable-feedback \
-%endif
-%if 0%{?tizen_2_2_compatibility}
-           --with-tizen-2-2-compatibility \
-%endif
-%if %{with wayland}
            --enable-efl=no \
-%else
-           --enable-efl=yes \
-%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -700,230 +456,6 @@ make clean
 
 %endif
 
-%if !0%{?disable_cxx03_build}
-#######################################################################
-#BUILD for cxx03 ABI
-#######################################################################
-
-# Set up the build via configure.
-#######################################################################
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if mobile || "undefined"
-%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
-
-%configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
-           --enable-shaderbincache=DISABLE --enable-profile=MOBILE \
-           --enable-tizen-major-version=%{tizen_version_major} \
-%if 0%{?tizen_version_major} >= 3
-           --enable-feedback \
-%endif
-           --enable-cxx03-abi=yes  \
-%if 0%{?tizen_2_2_compatibility}
-           --with-tizen-2-2-compatibility \
-%endif
-%if %{with wayland}
-           --enable-efl=no \
-%else
-           --enable-efl=yes \
-%endif
-%if 0%{?enable_debug}
-           --enable-debug \
-%endif
-%if 0%{?enable_trace}
-           --enable-trace \
-%endif
-           --enable-appfw=yes \
-           $configure_flags --libdir=%{_libdir} \
-           --enable-rename-so=no
-
-# Build.
-make %{?jobs:-j%jobs}
-
-pushd %{_builddir}/%{name}-%{version}/build/tizen
-%make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
-popd
-
-pushd %{buildroot}%{_libdir}
-for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.mobile"; done
-for FILE in libdali-*plugin.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
-popd
-
-make clean
-
-%endif
-
-#######################################################################
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if tv ||"undefined"
-%if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
-
-%configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
-           --enable-shaderbincache=DISABLE --enable-profile=TV \
-           --enable-tizen-major-version=%{tizen_version_major} \
-%if 0%{?tizen_version_major} >= 3
-           --enable-feedback \
-%endif
-           --enable-cxx03-abi=yes  \
-%if 0%{?tizen_2_2_compatibility}
-           --with-tizen-2-2-compatibility \
-%endif
-%if %{with wayland}
-           --enable-efl=no \
-%else
-           --enable-efl=yes \
-%endif
-%if 0%{?enable_debug}
-           --enable-debug \
-%endif
-%if 0%{?enable_trace}
-           --enable-trace \
-%endif
-           --enable-appfw=yes \
-           $configure_flags --libdir=%{_libdir} \
-           --enable-rename-so=no
-
-# Build.
-make %{?jobs:-j%jobs}
-
-pushd %{_builddir}/%{name}-%{version}/build/tizen
-%make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
-popd
-
-pushd %{buildroot}%{_libdir}
-for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.tv"; done
-for FILE in libdali-*plugin.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
-popd
-
-make clean
-%endif
-
-#######################################################################
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if wearable || "undefined"
-%if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
-
-%configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
-           --enable-shaderbincache=DISABLE --enable-profile=WEARABLE \
-           --enable-tizen-major-version=%{tizen_version_major} \
-%if 0%{?tizen_version_major} >= 3
-           --enable-feedback \
-%endif
-           --enable-cxx03-abi=yes \
-%if 0%{?tizen_2_2_compatibility}
-           --with-tizen-2-2-compatibility \
-%endif
-%if %{with wayland}
-           --enable-efl=no \
-%else
-           --enable-efl=yes \
-%endif
-%if 0%{?enable_debug}
-           --enable-debug \
-%endif
-%if 0%{?enable_trace}
-           --enable-trace \
-%endif
-           --enable-appfw=yes \
-           $configure_flags --libdir=%{_libdir} \
-           --enable-rename-so=no
-
-# Build.
-make %{?jobs:-j%jobs}
-
-pushd %{_builddir}/%{name}-%{version}/build/tizen
-%make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
-popd
-
-pushd %{buildroot}%{_libdir}
-for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.wearable"; done
-for FILE in libdali-*plugin.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
-popd
-
-make clean
-%endif
-
-#######################################################################
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if ivi ||"undefined"
-%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
-
-%configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
-           --enable-shaderbincache=DISABLE --enable-profile=IVI \
-           --enable-tizen-major-version=%{tizen_version_major} \
-%if 0%{?tizen_version_major} >= 3
-           --enable-feedback \
-%endif
-           --enable-cxx03-abi=yes  \
-%if 0%{?tizen_2_2_compatibility}
-           --with-tizen-2-2-compatibility \
-%endif
-%if %{with wayland}
-           --enable-efl=no \
-%else
-           --enable-efl=yes \
-%endif
-%if 0%{?enable_debug}
-           --enable-debug \
-%endif
-%if 0%{?enable_trace}
-           --enable-trace \
-%endif
-           --enable-appfw=yes \
-           $configure_flags --libdir=%{_libdir} \
-           --enable-rename-so=no
-
-# Build.
-make %{?jobs:-j%jobs}
-
-pushd %{_builddir}/%{name}-%{version}/build/tizen
-%make_install DALI_DATA_RW_DIR="%{dali_data_rw_dir}" DALI_DATA_RO_DIR="%{dali_data_ro_dir}"
-popd
-
-pushd %{buildroot}%{_libdir}
-for FILE in libdali-adap*.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE.ivi"; done
-for FILE in libdali-*plugin.so*; do mv "$FILE" "%{_builddir}/%{name}-%{version}/build/tizen/$FILE"; done
-popd
-
-make clean
-%endif
-
-#######################################################################
-# common
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if common ||"undefined"
-%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
-
-%configure --prefix=$PREFIX --with-jpeg-turbo --enable-gles=%{target_gles_version} \
-           --enable-shaderbincache=DISABLE --enable-profile=COMMON \
-           --enable-tizen-major-version=%{tizen_version_major} \
-%if 0%{?tizen_version_major} >= 3
-           --enable-feedback \
-%endif
-           --enable-cxx03-abi=yes  \
-%if 0%{?tizen_2_2_compatibility}
-           --with-tizen-2-2-compatibility \
-%endif
-%if %{with wayland}
-           --enable-efl=no \
-%else
-           --enable-efl=yes \
-%endif
-%if 0%{?enable_debug}
-           --enable-debug \
-%endif
-%if 0%{?enable_trace}
-           --enable-trace \
-%endif
-           --enable-appfw=yes \
-           $configure_flags --libdir=%{_libdir} \
-           --enable-rename-so=no
-
-# Build.
-make %{?jobs:-j%jobs}
-
-%endif
-%endif
-
 ##############################
 # Installation
 ##############################
@@ -957,9 +489,6 @@ pushd %{buildroot}%{_libdir}
 # if common ||"undefined"
 #%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
 rm -rf libdali-adaptor*.so
-%if !0%{?disable_cxx03_build}
-ln -s libdali-adaptor.so.0.0.0 libdali-adaptor-cxx03.so
-%endif
 ln -s libdali-adaptor-cxx11.so.0.0.0 libdali-adaptor.so
 #%endif
 
@@ -967,9 +496,6 @@ ln -s libdali-adaptor-cxx11.so.0.0.0 libdali-adaptor.so
 # if wearable || "undefined"
 %if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
 rm -rf libdali-adaptor*.so.wearable
-%if !0%{?disable_cxx03_build}
-ln -s libdali-adaptor.so.0.0.*.wearable libdali-adaptor-cxx03.so.wearable
-%endif
 ln -s libdali-adaptor-cxx11.so.0.0.*.wearable libdali-adaptor.so.wearable
 %endif
 
@@ -977,9 +503,6 @@ ln -s libdali-adaptor-cxx11.so.0.0.*.wearable libdali-adaptor.so.wearable
 # if tv ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
 rm -rf libdali-adaptor*.so.tv
-%if !0%{?disable_cxx03_build}
-ln -s libdali-adaptor.so.0.0.*.tv libdali-adaptor-cxx03.so.tv
-%endif
 ln -s libdali-adaptor-cxx11.so.0.0.*.tv libdali-adaptor.so.tv
 %endif
 
@@ -987,9 +510,6 @@ ln -s libdali-adaptor-cxx11.so.0.0.*.tv libdali-adaptor.so.tv
 # if ivi ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
 rm -rf libdali-adaptor*.so.ivi
-%if !0%{?disable_cxx03_build}
-ln -s libdali-adaptor.so.0.0.*.ivi libdali-adaptor-cxx03.so.ivi
-%endif
 ln -s libdali-adaptor-cxx11.so.0.0.*.ivi libdali-adaptor.so.ivi
 %endif
 
@@ -997,9 +517,6 @@ ln -s libdali-adaptor-cxx11.so.0.0.*.ivi libdali-adaptor.so.ivi
 # if mobile || "undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
 rm -rf libdali-adaptor*.so.mobile
-%if !0%{?disable_cxx03_build}
-ln -s libdali-adaptor.so.0.0.*.mobile libdali-adaptor-cxx03.so.mobile
-%endif
 ln -s libdali-adaptor-cxx11.so.0.0.*.mobile libdali-adaptor.so.mobile
 %endif
 popd
@@ -1105,77 +622,6 @@ exit 0
 exit 0
 %endif
 
-%if !0%{?disable_cxx03_build}
-##############################
-#cxx03 ABI
-#############################
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if mobile || "undefined"
-%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
-%post profile_mobile-cxx03
-pushd %{_libdir}
-for FILE in libdali-adaptor.so*.mobile; do ln -sf "$FILE" "${FILE%.mobile}"; done
-popd
-/sbin/ldconfig
-exit 0
-
-%postun profile_mobile-cxx03
-/sbin/ldconfig
-exit 0
-%endif
-
-##############################
-
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if tv ||"undefined"
-%if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
-%post profile_tv-cxx03
-pushd %{_libdir}
-for FILE in libdali-adaptor.so*.tv; do ln -sf "$FILE" "${FILE%.tv}"; done
-popd
-/sbin/ldconfig
-exit 0
-
-%postun profile_tv-cxx03
-/sbin/ldconfig
-exit 0
-%endif
-
-##############################
-
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if wearable || "undefined"
-%if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
-%post profile_wearable-cxx03
-pushd %{_libdir}
-for FILE in libdali-adaptor.so*.wearable; do ln -sf "$FILE" "${FILE%.wearable}"; done
-popd
-/sbin/ldconfig
-exit 0
-
-%postun profile_wearable-cxx03
-/sbin/ldconfig
-exit 0
-%endif
-
-##############################
-
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if ivi ||"undefined"
-%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
-%post profile_ivi-cxx03
-pushd %{_libdir}
-for FILE in libdali-adaptor.so*.ivi; do ln -sf "$FILE" "${FILE%.ivi}"; done
-popd
-/sbin/ldconfig
-exit 0
-
-%postun profile_ivi-cxx03
-/sbin/ldconfig
-exit 0
-%endif
-%endif
-
 ##############################
 # Files in Binary Packages
 ##############################
@@ -1199,43 +645,13 @@ exit 0
 %exclude %{_libdir}/libdali-adap*.so*.ivi
 #%endif
 
-%if !0%{?disable_cxx03_build}
-%files cxx03
-%manifest dali-adaptor.manifest
-%defattr(-,root,root,-)
-%dir %{user_shader_cache_dir}
-%{_bindir}/*
-%license LICENSE
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if common ||"undefined"
-#%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
-%defattr(-,root,root,-)
-%{_libdir}/libdali-adaptor.so.0*
-%{_libdir}/libdali-adaptor-cxx03.so
-%exclude %{_libdir}/libdali-adap*.so*.mobile
-%exclude %{_libdir}/libdali-adap*.so*.wearable
-%exclude %{_libdir}/libdali-adap*.so*.tv
-%exclude %{_libdir}/libdali-adap*.so*.ivi
-#%endif
-
-%if 0%{?tizen_version_major} >= 3
-%files dali-feedback-plugin-cxx03
-%manifest dali-adaptor.manifest
-%defattr(-,root,root,-)
-%{_libdir}/libdali-feedback-plugin.so*
-%{dali_plugin_sound_files}/*
-%endif
-%endif
-
 #################################################
 
-%if 0%{?tizen_version_major} >= 3
 %files dali-feedback-plugin
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
 %{_libdir}/libdali-feedback-plugin-cxx11.so*
 %{dali_plugin_sound_files}/*
-%endif
 
 #################################################
 
@@ -1300,69 +716,3 @@ exit 0
 %{dev_include_path}/dali/integration-api/adaptors/*
 %{_libdir}/pkgconfig/dali-adaptor-integration.pc
 
-%if !0%{?disable_cxx03_build}
-################################################
-# cxx03 ABI
-################################################
-
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if common ||"undefined"
-%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
-%files profile_common-cxx03
-# default .so files are housed in the main pkg.
-%endif
-
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if mobile || "undefined"
-%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
-%files profile_mobile-cxx03
-%manifest dali-adaptor.manifest
-%defattr(-,root,root,-)
-%{_libdir}/libdali-adaptor-cxx03.so.mobile
-%{_libdir}/libdali-adaptor.so.0*mobile
-%endif
-
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if tv ||"undefined"
-%if "%{?profile}" != "wearable" && "%{?profile}" != "common" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
-%files profile_tv-cxx03
-%manifest dali-adaptor.manifest
-%defattr(-,root,root,-)
-%{_libdir}/libdali-adaptor-cxx03.so.tv
-%{_libdir}/libdali-adaptor.so.0*.tv
-%endif
-
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if wearable || "undefined"
-%if "%{?profile}" != "mobile" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "common"
-%files profile_wearable-cxx03
-%manifest dali-adaptor.manifest
-%defattr(-,root,root,-)
-%{_libdir}/libdali-adaptor-cxx03.so.wearable
-%{_libdir}/libdali-adaptor.so.0*.wearable
-%endif
-
-# This is for backward-compatibility. This does not deteriorate 4.0 Configurability
-# if ivi ||"undefined"
-%if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "common" && "%{?profile}" != "mobile"
-%files profile_ivi-cxx03
-%manifest dali-adaptor.manifest
-%defattr(-,root,root,-)
-%{_libdir}/libdali-adaptor-cxx03.so.ivi
-%{_libdir}/libdali-adaptor.so.0*.ivi
-%endif
-
-
-%files devel-cxx03
-%defattr(-,root,root,-)
-%{dev_include_path}/dali/dali.h
-%{dev_include_path}/dali/public-api/*
-%{dev_include_path}/dali/devel-api/*
-%{dev_include_path}/dali/doc/*
-%{_libdir}/pkgconfig/dali-adaptor-cxx03.pc
-
-%files integration-devel-cxx03
-%defattr(-,root,root,-)
-%{dev_include_path}/dali/integration-api/adaptors/*
-%{_libdir}/pkgconfig/dali-adaptor-integration-cxx03.pc
-%endif