Revert "[Tizen] ecore-wl2: applying ecore-wl2"
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
index 77c210c..3c87990 100644 (file)
@@ -19,7 +19,7 @@
 
 Name:       dali-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    1.2.57
+Version:    1.3.17
 Release:    1
 Group:      System/Libraries
 License:    Apache-2.0 and BSD-3-Clause and MIT
@@ -57,6 +57,7 @@ BuildRequires:  pkgconfig(screen_connector_provider)
 
 BuildRequires:  pkgconfig(gles20)
 BuildRequires:  pkgconfig(glesv2)
+BuildRequires:  pkgconfig(ttrace)
 
 %if !0%{?disable_cxx03_build}
 BuildRequires:  dali-devel-cxx03
@@ -84,6 +85,8 @@ BuildRequires:  fribidi-devel
 BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(capi-system-sensor)
 
+BuildRequires:  pkgconfig(libcrypto)
+
 %if %{with wayland}
 
 ####### BUILDING FOR WAYLAND #######
@@ -115,13 +118,13 @@ BuildRequires:  pkgconfig(utilX)
 %endif
 
 # for dali-adaptor
-BuildRequires:  pkgconfig(evas)
-
 %if 0%{?tizen_version_major} == 3
 BuildRequires:  pkgconfig(capi-appfw-application)
 BuildRequires:  pkgconfig(elementary)
 %else
 BuildRequires:  pkgconfig(appcore-ui)
+BuildRequires:  pkgconfig(appcore-widget-base)
+BuildRequires:  pkgconfig(bundle)
 BuildRequires:  pkgconfig(capi-appfw-app-common)
 BuildRequires:  pkgconfig(capi-appfw-app-control)
 BuildRequires:  pkgconfig(ecore-imf)
@@ -135,9 +138,11 @@ BuildRequires:  pkgconfig(mm-sound)
 BuildRequires:  pkgconfig(feedback)
 %endif
 
-# for videoplayer Plugin
-BuildRequires:  pkgconfig(capi-media-player)
-
+# for Web Engine Lite Plugin
+%if 0%{?enable_web_engine_lite}
+BuildRequires: lightweight-web-engine
+BuildRequires: lightweight-web-engine-devel
+%endif
 
 # for multiprofile
 Requires:   %{name}-compat = %{version}-%{release}
@@ -370,16 +375,14 @@ Requires:   %{name} = %{version}-%{release}
 Feedback plugin to play haptic and audio feedback for Dali
 
 ##############################
-# Dali VideoPlayer Plugin
+# Dali WebEngineLite Plugin
 ##############################
-%if %{with wayland}
 
-%package dali-video-player-plugin
-Summary:    Plugin to play a video file for Dali
+%package dali-web-engine-lite-plugin
+Summary:    Plugin WebEngineLite for Dali
 Group:      System/Libraries
-%description dali-video-player-plugin
-VideoPlayer plugin to play a video file for Dali
-%endif
+%description dali-web-engine-lite-plugin
+WebEngineLite plugin for Dali
 
 %if !0%{?disable_cxx03_build}
 ##############################
@@ -394,16 +397,14 @@ Requires:   %{name}-cxx03 = %{version}-%{release}
 Feedback plugin to play haptic and audio feedback for Dali
 
 ##############################
-# Dali VideoPlayer Plugin
+# Dali WebEngineLite Plugin
 ##############################
-%if %{with wayland}
 
-%package dali-video-player-plugin-cxx03
-Summary:    Plugin to play a video file for Dali with cxx03 abi
+%package dali-web-engine-lite-plugin-cxx03
+Summary:    Plugin WebEngineLite for Dali with cxx03 abi
 Group:      System/Libraries
-%description dali-video-player-plugin-cxx03
-VideoPlayer plugin to play a video file for Dali
-%endif
+%description dali-web-engine-lite-plugin-cxx03
+WebEngineLite plugin for Dali
 %endif
 
 ##############################
@@ -492,7 +493,6 @@ TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TI
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -501,6 +501,9 @@ TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TI
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -535,7 +538,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -544,6 +546,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -577,7 +582,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -586,6 +590,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -619,7 +626,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -628,6 +634,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -653,7 +662,7 @@ make clean
 %endif
 
 #######################################################################
-# common ( build dali_videoplayer_plugin for common uses )
+# common
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if common ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
@@ -663,7 +672,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -672,6 +680,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -714,7 +725,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -724,6 +734,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -758,7 +771,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -768,6 +780,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -801,7 +816,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -811,6 +825,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -844,7 +861,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -854,6 +870,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -877,7 +896,7 @@ make clean
 %endif
 
 #######################################################################
-# common ( build dali_videoplayer_plugin for common uses )
+# common
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if common ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
@@ -888,7 +907,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -898,6 +916,9 @@ make clean
 %else
            --enable-efl=yes \
 %endif
+%if 0%{?enable_web_engine_lite}
+           --enable-web-engine-lite \
+%endif
 %if 0%{?enable_debug}
            --enable-debug \
 %endif
@@ -1024,18 +1045,11 @@ exit 0
 /sbin/ldconfig
 exit 0
 
-%if %{with wayland}
-%post dali-video-player-plugin
-/sbin/ldconfig
-exit 0
-%endif
-
-%if %{with wayland}
-%postun dali-video-player-plugin
+#%if %{with wayland}
+%post dali-web-engine-lite-plugin
 /sbin/ldconfig
 exit 0
-%endif
-
+#%endif
 
 ##############################
 
@@ -1220,15 +1234,15 @@ exit 0
 %exclude %{_libdir}/libdali-adap*.so*.ivi
 #%endif
 
-%if %{with wayland}
-%files dali-video-player-plugin-cxx03
+%if 0%{?tizen_version_major} >= 3
+%if 0%{?enable_web_engine_lite}
+%files dali-web-engine-lite-plugin-cxx03
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
-%{_libdir}/libdali-video-player-plugin.so*
+%{_libdir}/libdali-web-engine-lite-plugin.so*
 %license LICENSE
 %endif
 
-%if 0%{?tizen_version_major} >= 3
 %files dali-feedback-plugin-cxx03
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
@@ -1239,15 +1253,15 @@ exit 0
 
 #################################################
 
-%if %{with wayland}
-%files dali-video-player-plugin
+%if 0%{?tizen_version_major} >= 3
+%if 0%{?enable_web_engine_lite}
+%files dali-web-engine-lite-plugin
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
-%{_libdir}/libdali-video-player-plugin-cxx11.so*
+%{_libdir}/libdali-web-engine-lite-plugin-cxx11.so*
 %license LICENSE
 %endif
 
-%if 0%{?tizen_version_major} >= 3
 %files dali-feedback-plugin
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)