Enable GLES 3.0 by default.
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
index 9df4fbe..3788707 100644 (file)
 
 Name:       dali-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    1.2.32
+Version:    1.2.43
 Release:    1
 Group:      System/Libraries
-License:    Apache-2.0 and BSD-2-Clause and MIT
+License:    Apache-2.0 and BSD-3-Clause and MIT
 URL:        https://review.tizen.org/git/?p=platform/core/uifw/dali-adaptor.git;a=summary
 Source0:    %{name}-%{version}.tar.gz
 
@@ -27,7 +27,7 @@ Requires:       giflib
 
 #need libtzplatform-config for directory if tizen version is 3.x
 
-%if "%{tizen_version_major}" >= "3"
+%if 0%{?tizen_version_major} >= 3
 %define tizen_platform_config_supported 1
 BuildRequires:  pkgconfig(libtzplatform-config)
 %endif
@@ -231,7 +231,7 @@ VideoPlayer plugin to play a video file for Dali
 
 #Use TZ_PATH when tizen version is 3.x or greater
 
-%if "%{tizen_version_major}" >= "3"
+%if 0%{?tizen_version_major} >= 3
 %define dali_data_rw_dir         %TZ_SYS_RO_SHARE/dali/
 %define dali_data_ro_dir         %TZ_SYS_RO_SHARE/dali/
 %define font_preloaded_path      %TZ_SYS_RO_SHARE/fonts/
@@ -288,8 +288,8 @@ FONT_CONFIGURATION_FILE="%{font_configuration_file}" ; export FONT_CONFIGURATION
 TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TIZEN_PLATFORM_CONFIG_SUPPORTED
 %endif
 
-# Default to GLES 2.0 if not specified.
-%{!?target_gles_version: %define target_gles_version 20}
+# Default to GLES 3.0 if not specified.
+%{!?target_gles_version: %define target_gles_version 30}
 
 #--enable-efl=no \ # only affects dali-adaptor-uv
 #--enable-appfw=yes \ # affects both dali-adaptor & dali-adaptor-uv
@@ -431,5 +431,6 @@ exit 0
 %manifest dali-adaptor.manifest
 %defattr(-,root,root,-)
 %{_libdir}/libdali-video-player-plugin.so*
+%license LICENSE
 %endif
 %endif