Revert "[Tizen] Implement WebEngineLite interface and plugin for Minimized Web Engine"
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
index 226f9b8..1d45765 100644 (file)
@@ -19,7 +19,7 @@
 
 Name:       dali-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    1.2.58
+Version:    1.3.17
 Release:    1
 Group:      System/Libraries
 License:    Apache-2.0 and BSD-3-Clause and MIT
@@ -57,6 +57,7 @@ BuildRequires:  pkgconfig(screen_connector_provider)
 
 BuildRequires:  pkgconfig(gles20)
 BuildRequires:  pkgconfig(glesv2)
+BuildRequires:  pkgconfig(ttrace)
 
 %if !0%{?disable_cxx03_build}
 BuildRequires:  dali-devel-cxx03
@@ -84,6 +85,8 @@ BuildRequires:  fribidi-devel
 BuildRequires:  pkgconfig(capi-system-info)
 BuildRequires:  pkgconfig(capi-system-sensor)
 
+BuildRequires:  pkgconfig(libcrypto)
+
 %if %{with wayland}
 
 ####### BUILDING FOR WAYLAND #######
@@ -115,13 +118,13 @@ BuildRequires:  pkgconfig(utilX)
 %endif
 
 # for dali-adaptor
-BuildRequires:  pkgconfig(evas)
-
 %if 0%{?tizen_version_major} == 3
 BuildRequires:  pkgconfig(capi-appfw-application)
 BuildRequires:  pkgconfig(elementary)
 %else
 BuildRequires:  pkgconfig(appcore-ui)
+BuildRequires:  pkgconfig(appcore-widget-base)
+BuildRequires:  pkgconfig(bundle)
 BuildRequires:  pkgconfig(capi-appfw-app-common)
 BuildRequires:  pkgconfig(capi-appfw-app-control)
 BuildRequires:  pkgconfig(ecore-imf)
@@ -135,10 +138,6 @@ BuildRequires:  pkgconfig(mm-sound)
 BuildRequires:  pkgconfig(feedback)
 %endif
 
-# for videoplayer Plugin
-BuildRequires:  pkgconfig(capi-media-player)
-
-
 # for multiprofile
 Requires:   %{name}-compat = %{version}-%{release}
 Recommends: %{name}-profile_common = %{version}-%{release}
@@ -369,18 +368,6 @@ Requires:   %{name} = %{version}-%{release}
 %description dali-feedback-plugin
 Feedback plugin to play haptic and audio feedback for Dali
 
-##############################
-# Dali VideoPlayer Plugin
-##############################
-%if %{with wayland}
-
-%package dali-video-player-plugin
-Summary:    Plugin to play a video file for Dali
-Group:      System/Libraries
-%description dali-video-player-plugin
-VideoPlayer plugin to play a video file for Dali
-%endif
-
 %if !0%{?disable_cxx03_build}
 ##############################
 # Dali Feedback Plugin cxx03
@@ -393,17 +380,6 @@ Requires:   %{name}-cxx03 = %{version}-%{release}
 %description dali-feedback-plugin-cxx03
 Feedback plugin to play haptic and audio feedback for Dali
 
-##############################
-# Dali VideoPlayer Plugin
-##############################
-%if %{with wayland}
-
-%package dali-video-player-plugin-cxx03
-Summary:    Plugin to play a video file for Dali with cxx03 abi
-Group:      System/Libraries
-%description dali-video-player-plugin-cxx03
-VideoPlayer plugin to play a video file for Dali
-%endif
 %endif
 
 ##############################
@@ -492,7 +468,6 @@ TIZEN_PLATFORM_CONFIG_SUPPORTED="%{tizen_platform_config_supported}" ; export TI
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -535,7 +510,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -577,7 +551,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -619,7 +592,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -653,7 +625,7 @@ make clean
 %endif
 
 #######################################################################
-# common ( build dali_videoplayer_plugin for common uses )
+# common
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if common ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
@@ -663,7 +635,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
 %endif
@@ -714,7 +685,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -758,7 +728,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -801,7 +770,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -844,7 +812,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -877,7 +844,7 @@ make clean
 %endif
 
 #######################################################################
-# common ( build dali_videoplayer_plugin for common uses )
+# common
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
 # if common ||"undefined"
 %if "%{?profile}" != "wearable" && "%{?profile}" != "tv" && "%{?profile}" != "ivi" && "%{?profile}" != "mobile"
@@ -888,7 +855,6 @@ make clean
 %if 0%{?tizen_version_major} >= 3
            --enable-feedback \
 %endif
-           --enable-videoplayer \
            --enable-cxx03-abi=yes  \
 %if 0%{?tizen_2_2_compatibility}
            --with-tizen-2-2-compatibility \
@@ -1024,19 +990,6 @@ exit 0
 /sbin/ldconfig
 exit 0
 
-%if %{with wayland}
-%post dali-video-player-plugin
-/sbin/ldconfig
-exit 0
-%endif
-
-%if %{with wayland}
-%postun dali-video-player-plugin
-/sbin/ldconfig
-exit 0
-%endif
-
-
 ##############################
 
 # This is for backward-compatibility. This does not deteriorate 4.0 Configurability
@@ -1220,14 +1173,6 @@ exit 0
 %exclude %{_libdir}/libdali-adap*.so*.ivi
 #%endif
 
-%if %{with wayland}
-%files dali-video-player-plugin-cxx03
-%manifest dali-adaptor.manifest
-%defattr(-,root,root,-)
-%{_libdir}/libdali-video-player-plugin.so*
-%license LICENSE
-%endif
-
 %if 0%{?tizen_version_major} >= 3
 %files dali-feedback-plugin-cxx03
 %manifest dali-adaptor.manifest
@@ -1239,14 +1184,6 @@ exit 0
 
 #################################################
 
-%if %{with wayland}
-%files dali-video-player-plugin
-%manifest dali-adaptor.manifest
-%defattr(-,root,root,-)
-%{_libdir}/libdali-video-player-plugin-cxx11.so*
-%license LICENSE
-%endif
-
 %if 0%{?tizen_version_major} >= 3
 %files dali-feedback-plugin
 %manifest dali-adaptor.manifest