DALi Version 2.2.1
[platform/core/uifw/dali-adaptor.git] / packaging / dali-adaptor.spec
index 702a44f..1b02016 100644 (file)
@@ -17,7 +17,7 @@
 
 Name:       dali2-adaptor
 Summary:    The DALi Tizen Adaptor
-Version:    2.1.13
+Version:    2.2.1
 Release:    1
 Group:      System/Libraries
 License:    Apache-2.0 and BSD-3-Clause and MIT
@@ -95,7 +95,7 @@ BuildRequires:  pkgconfig(ecore-wayland)
 BuildRequires:  pkgconfig(libtbm)
 
 # for the adaptor
-BuildRequires:  pkgconfig(appcore-ui)
+BuildRequires:  pkgconfig(app-core-ui-cpp)
 BuildRequires:  pkgconfig(appcore-widget-base)
 BuildRequires:  pkgconfig(bundle)
 BuildRequires:  pkgconfig(capi-appfw-app-common)
@@ -270,7 +270,7 @@ CXXFLAGS+=" -D_ARCH_ARM_ -lgcc"
 
 CFLAGS+=" -DWAYLAND"
 CXXFLAGS+=" -DWAYLAND"
-cmake_flags=" -DENABLE_WAYLAND=ON -DENABLE_ATSPI=ON"
+cmake_flags=" -DENABLE_WAYLAND=ON -DENABLE_ATSPI=ON -DENABLE_TRACE=ON"
 
 # Use this conditional when Tizen version is 5.x or greater
 %if 0%{?tizen_version_major} >= 5
@@ -291,10 +291,6 @@ CXXFLAGS+=" -DOVER_TIZEN_VERSION_7"
 cmake_flags+=" -DCMAKE_BUILD_TYPE=Debug"
 %endif
 
-%if 0%{?enable_trace}
-cmake_flags+=" -DENABLE_TRACE=ON"
-%endif
-
 %if 0%{?enable_logging}
 cmake_flags+=" -DENABLE_NETWORK_LOGGING=ON"
 %endif