[Tizen] Implement WebEngineLite interface and plugin for Minimized Web Engine
[platform/core/uifw/dali-adaptor.git] / build / tizen / plugins / configure.ac
index 3bd8eb9..cabafda 100644 (file)
@@ -23,16 +23,14 @@ AM_CONDITIONAL([UBUNTU_PROFILE], [test x$enable_profile = xUBUNTU])
 AM_CONDITIONAL([WAYLAND], [test x$enable_wayland = xyes])
 
 AM_CONDITIONAL([USE_FEEDBACK], [test x$enable_feedback = xyes])
-AM_CONDITIONAL([USE_VIDEOPLAYER], [test x$enable_videoplayer = xyes])
+AM_CONDITIONAL([USE_WEBENGINELITE], [test x$enable_web_engine_lite = xyes])
 
-if test "x$enable_wayland" = "xyes"; then
-if test "x$enable_videoplayer" = "xyes"; then
-if test "x$enable_profile" != "xUBUNTU"; then
-PKG_CHECK_MODULES(CAPI_MEDIA_PLAYER, capi-media-player)
-PKG_CHECK_MODULES(ECORE_WAYLAND, ecore-wayland)
+AM_CONDITIONAL([ENABLE_CXX03_ABI], [test x$enable_cxx03_abi = xyes])
+AM_CONDITIONAL([ENABLE_RENAME_SO], [test x$enable_rename_so = xyes])
+
+if test "x$enable_cxx03_abi" = "xyes"; then
+ DALI_ADAPTOR_CFLAGS="$DALI_ADAPTOR_CFLAGS -D_GLIBCXX_USE_CXX11_ABI=0"
 fi
-fi # enable_videoplayer
-fi # enable_wayland
 
 if test "x$enable_feedback" = "xyes"; then
 if test "x$enable_profile" != "xUBUNTU"; then
@@ -43,6 +41,16 @@ PKG_CHECK_MODULES(MMFSOUND, mm-sound)
 fi # check UNBUNTU
 fi # enable_feedback
 
+if test "x$enable_web_engine_lite" = "xyes"; then
+if test "x$enable_profile" != "xUBUNTU"; then
+
+PKG_CHECK_MODULES(FEEDBACK, feedback)
+PKG_CHECK_MODULES(WEBENGINELITE, lightweight-web-engine)
+#PKG_CHECK_MODULES(MMFSOUND, mm-sound)
+
+fi # check UNBUNTU
+fi # enable_web_engine_lite
+
 AC_CONFIG_FILES(Makefile)
 
 AC_OUTPUT