[Tizen] Implement WebEngineLite interface and plugin for Minimized Web Engine
[platform/core/uifw/dali-adaptor.git] / build / tizen / configure.ac
index 76b59f1..0197e4f 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (c) 2015 Samsung Electronics Co., Ltd.
+# Copyright (c) 2017 Samsung Electronics Co., Ltd.
 #
 # Licensed under the Apache License, Version 2.0 (the "License");
 # you may not use this file except in compliance with the License.
@@ -18,26 +18,22 @@ m4_define([dali_version],[0.1.0])
 AC_INIT([dali], [dali_version])
 AM_INIT_AUTOMAKE([-Wall foreign])
 
-AC_ARG_WITH([libuv],
-              [AC_HELP_STRING([--with-libuv],
-                              [Path that contains libuv headers. Setting this configures DALi to work with LibUV mainloop used in Node.JS.
-                              For example /usr/tmp/downloads/node/deps/uv/include/ ])],
-              [with_libuv=$withval],
-              [with_libuv=no])
-
 AC_ARG_ENABLE([feedback],
               [AC_HELP_STRING([ --enable-feedback],
                               [Enable feedback plugin])],
               [enable_feedback=yes],
               [enable_feedback=no])
 
+AC_ARG_ENABLE([web_engine_lite],
+              [AC_HELP_STRING([ --enable-web-engine-lite],
+                              [Enable web engine lite plugin])],
+              [enable_web_engine_lite=yes],
+              [enable_web_engine_lite=no])
+
 AC_CONFIG_SUBDIRS(adaptor)
-if test "x$with_libuv" != "xno"; then
-  # build dali-adaptor & dali-adaptor-uv
-  AC_CONFIG_SUBDIRS(adaptor-uv)
-fi
-if test "x$enable_feedback" = "xyes"; then
-  # build dali-adaptor & dali-adaptor-uv & plugins
+
+if test "x$enable_feedback" = "xyes"|| test "x$enable_web_engine_lite" = "xyes"; then
+  # build dali-adaptor & plugins
   AC_CONFIG_SUBDIRS(plugins)
 fi
 #else