[Tizen] Replace aul_rsm with screen_connector_provider and enable for only wearable...
[platform/core/uifw/dali-adaptor.git] / build / tizen / adaptor / configure.ac
index 1fbb476..062f15e 100644 (file)
@@ -50,7 +50,6 @@ PKG_CHECK_MODULES(TTRACE,  ttrace, AC_DEFINE(ENABLE_TTRACE, 1, [ttrace available
                   [ AC_MSG_NOTICE([Tizen Trace not avaiable]) ]
                   )
 
-
 # Currently, dali-adaptor always requires EFL on all platforms.
 # (on Wayland & X11, on Tizen devices & Ubuntu PC).
 enable_efl=yes
@@ -223,6 +222,13 @@ fi
 
 if test "x$enable_profile" = "xWEARABLE"; then
 PKG_CHECK_MODULES(OPENGLES20, glesv2)
+PKG_CHECK_MODULES(SCREENCONNECTORPROVIDER, screen_connector_provider)
+PKG_CHECK_MODULES(APPFW_WATCH, capi-appfw-watch-application,
+   [watch_available=yes], [watch_available=no] )
+PKG_CHECK_MODULES(APPCORE_WATCH, appcore-watch)
+if test "x$watch_available" = "xyes"; then
+  DALI_ADAPTOR_CFLAGS="$DALI_ADAPTOR_CFLAGS -DAPPCORE_WATCH_AVAILABLE"
+fi
 fi
 
 if test "x$enable_profile" = "xTV"; then
@@ -292,7 +298,7 @@ fi
 # common profile currently does not have wayland extensions like xdg-shell
 if test "x$enable_wayland" = "xyes"; then
 if test "x$enable_profile" != "xCOMMON"; then
-PKG_CHECK_MODULES(WAYLAND_EXTENSION, xdg-shell-client)
+PKG_CHECK_MODULES(WAYLAND_EXTENSION, xdg-shell-client text-client input-method-client)
 fi
 fi
 AM_CONDITIONAL([USE_ECORE_WAYLAND], [test "$DALI_USE_ECORE_WAYLAND" -eq 1])
@@ -309,6 +315,12 @@ else
   dataReadOnlyDir=${prefix}/share/dali/
 fi
 
+if test x$TIZEN_PLATFORM_CONFIG_SUPPORTED != x; then
+  tizenPlatformConfigSupported=$TIZEN_PLATFORM_CONFIG_SUPPORTED
+else
+  tizenPlatformConfigSupported=0
+fi
+
 if test x$FONT_CONFIGURATION_FILE != x; then
   fontConfigurationFile=$FONT_CONFIGURATION_FILE
 fi
@@ -318,6 +330,7 @@ AC_SUBST(dataReadOnlyDir)
 AC_SUBST(DALI_ADAPTOR_CFLAGS)
 AC_SUBST(DALI_PROFILE_CFLAGS)
 AC_SUBST(fontConfigurationFile)
+AC_SUBST(tizenPlatformConfigSupported)
 
 # Specify the include directory for development headers
 #devincludepath=${includedir}/dali/internal
@@ -357,6 +370,7 @@ Configuration
   Building with EFL Libraries:      $enable_efl
   Using Tizen APP FW libraries:     $enable_appfw
   OpenGL ES version:                $enable_gles
+  Tizen Platform Config supported   $tizenPlatformConfigSupported
 "
 # optional output of node.js source path if we're building with libuv
 if test "x$build_for_libuv" != "xno"; then