Fix build errors in adaptor-uv by ecore wayland.
[platform/core/uifw/dali-adaptor.git] / build / tizen / adaptor-uv / configure.ac
old mode 100644 (file)
new mode 100755 (executable)
index e61fccf..33cc667
@@ -194,6 +194,13 @@ AC_ARG_ENABLE([profile],
               [enable_profile=$enableval],
               [enable_profile=UBUNTU])
 
+# Tizen Major version
+AC_ARG_ENABLE([tizen-major-version],
+              [AC_HELP_STRING([--enable-tizen-major-version],
+                              [Specify the Tizen Major version for backwards compatibility])],
+              [enable-tizen-major-version=$enableval],
+              [enable-tizen-major-version=0])
+
 # Ensure valid profile selected
 if test "x$enable_profile" != "xCOMMON" -a "x$enable_profile" != "xMOBILE" -a "x$enable_profile" != "xWEARABLE" -a "x$enable_profile" != "xTV" -a "x$enable_profile" != "xIVI" -a "x$enable_profile" != "xUBUNTU"; then
   AC_MSG_ERROR([$enable_profile is an invalid profile])
@@ -215,6 +222,7 @@ AM_CONDITIONAL([UBUNTU_PROFILE], [test x$enable_profile = xUBUNTU])
 AM_CONDITIONAL([WAYLAND], [test x$enable_wayland = xyes])
 AM_CONDITIONAL([USE_EFL], [test x$enable_efl = xyes])
 AM_CONDITIONAL([USE_APPFW], [test x$enable_appfw = xyes])
+AM_CONDITIONAL([USE_APPFW_EFL_BASE], [test x$enable_tizen_major_version = x3])
 
 AM_CONDITIONAL([ENABLE_NETWORK_LOGGING], [test x$enable_networklogging = xyes])
 
@@ -267,8 +275,14 @@ fi
 fi # ubuntu profile test
 
 if test "x$enable_appfw" = "xyes"; then
-PKG_CHECK_MODULES(CAPI_APPFW_APPLICATION, capi-appfw-application)
 PKG_CHECK_MODULES(CAPI_SYSTEM_SYSTEM_SETTINGS, capi-system-system-settings)
+if test "x$enable_tizen_major_version" = "x3"; then
+PKG_CHECK_MODULES(CAPI_APPFW_APPLICATION, capi-appfw-application)
+else
+PKG_CHECK_MODULES(CAPI_APPFW_APPLICATION, appcore-ui)
+PKG_CHECK_MODULES(CAPI_APPFW_COMMON, capi-appfw-app-common)
+PKG_CHECK_MODULES(CAPI_APPFW_CONTROL, capi-appfw-app-control)
+fi
 fi
 
 # Using EFL api's for  WAYLAND AND X11 to run on ecore mainloop
@@ -289,10 +303,9 @@ fi
 
 else
 
-# For adaptors/mobile/native-render-surface-factory.cpp
-PKG_CHECK_MODULES(ECORE_WAYLAND, ecore-wayland)
-
-if test "x$enable_profile" = "xIVI"; then
+# dali-adaptor-uv needs ecore-wayland even if enable_efl==no
+# because NativeRenderSurface uses it.
+if test "x$enable_profile" != "xUBUNTU"; then
 PKG_CHECK_MODULES(ECORE_WAYLAND, ecore-wayland)
 fi
 
@@ -307,13 +320,6 @@ PKG_CHECK_MODULES(WAYLAND, [ egl wayland-egl wayland-client >= 1.2.0 xkbcommon l
 fi
 fi
 
-# remove this when we update common repos
-# common profile currently does not have wayland extensions like xdg-shell
-if test "x$enable_wayland" = "xyes"; then
-if test "x$enable_profile" != "xCOMMON"; then
-PKG_CHECK_MODULES(WAYLAND_EXTENSION, xdg-shell-client text-client input-method-client)
-fi
-fi
 AM_CONDITIONAL([USE_ECORE_WAYLAND], [test "$DALI_USE_ECORE_WAYLAND" -eq 1])
 
 if test x$DALI_DATA_RW_DIR != x; then