Add option to execute unittest in building package
[platform/core/uifw/capi-ui-sticker.git] / packaging / capi-ui-sticker.spec
index 99bc0c4..031c8a9 100644 (file)
@@ -183,12 +183,14 @@ install -m 0644 %SOURCE3 %{buildroot}%{_sysconfdir}/dbus-1/system.d/capi-ui-stic
 
 %check
 %if 0%{?gcov:1}
+%if 0%{?run_unittest:1}
 ctest --output-on-failure %{?_smp_mflags}
 lcov -c --ignore-errors mismatch,graph,unused --no-external -q -d . -o capi-ui-sticker.info
 genhtml capi-ui-sticker.info -o capi-ui-sticker.out
 zip -r capi-ui-sticker.zip capi-ui-sticker.out capi-ui-sticker.info
 install -m 0644 capi-ui-sticker.zip %{buildroot}%{_datadir}/gcov
 %endif
+%endif
 
 %post
 /sbin/ldconfig