spec file, manifest and gbs.conf adapted for Tizen
[platform/core/uifw/at-spi2-atk.git] / packaging / at-spi2-atk.spec
1 %bcond_with x
2
3 Name: at-spi2-atk
4 Version: 2_12_0
5 Release: 1
6 Summary: Assistive Technology Service Provider Interface - GTK+ module
7 License: LGPL-2.0+
8 Group: System/Libraries
9 Url: http://www.gnome.org/
10 Source: http://download.gnome.org/sources/at-spi2-atk/2.12/%{name}-2.12.tar.xz
11 Source1001: %{name}.manifest
12 Requires: at-spi2-core
13 BuildRequires: dbus-devel
14 BuildRequires: glib2-devel
15 BuildRequires: atk-devel
16 BuildRequires: at-spi2-core-devel
17 BuildRequires: gettext
18 %if ! %{with x}
19 ExclusiveArch:
20 %endif
21
22 %description
23 AT-SPI is a general interface for applications to make use of the
24 accessibility toolkit. This version is based on dbus.
25
26 %package -n libatk-bridge-2_0-0
27 Summary: ATK/D-Bus bridging library
28 Group: System/Libraries
29
30 %description -n libatk-bridge-2_0-0
31 AT-SPI is a general interface for applications to make use of the
32 accessibility toolkit. This version is based on dbus.
33
34 The package contains a ATK/D-Bus bridge library.
35
36 %package devel
37 Summary: Assistive Technology Service Provider Interface - Developent files
38 Group: System/Libraries
39 Requires: libatk-bridge-2_0-0 = %{version}
40
41 %description devel
42 AT-SPI is a general interface for applications to make use of the
43 accessibility toolkit. This version is based on dbus.
44
45 %prep
46 %setup -q
47 cp %{SOURCE1001} .
48
49 %build
50 %autogen
51 %__make %{?_smp_flags}
52
53 %install
54 rm -rf %{buildroot}
55 %make_install
56 find %{buildroot} -name '*.la' -or -name '*.a' | xargs rm -f
57 find %{buildroot} -name '*.desktop' | xargs rm -f
58
59 %clean
60 rm -rf %{buildroot}
61
62 %post -n libatk-bridge-2_0-0 -p /sbin/ldconfig
63
64 %postun -n libatk-bridge-2_0-0 -p /sbin/ldconfig
65
66 %files -n libatk-bridge-2_0-0
67 %manifest %{name}.manifest
68 %defattr(-,root,root)
69 %{_libdir}/libatk-bridge-2.0.so.*
70 %{_libdir}/gtk-2.0/modules/libatk-bridge.so
71
72 %files devel
73 %manifest %{name}.manifest
74 %defattr(-,root,root)
75 %{_includedir}/at-spi2-atk/2.0/atk-bridge.h
76 %{_libdir}/libatk-bridge-2.0.so
77 %{_libdir}/pkgconfig/atk-bridge-2.0.pc
78
79 %changelog
80 * Mon Mar 25 2013 tomasz.duszynski@comarch.com
81 - Initial packaging of at-spi2-atk (2.5.92)
82