Make spec compliant with gbs --incremental
[platform/core/test/security-tests.git] / packaging / security-tests.spec
index f96f79b..9208e72 100644 (file)
@@ -42,7 +42,6 @@ Security tests repository - for tests that can't be kept together with code.
 
 %prep
 %setup -q
-cp %{SOURCE1} .
 
 %build
 export LDFLAGS+="-Wl,--rpath=%{_prefix}/lib"
@@ -71,6 +70,7 @@ id -u  security_test_user 1>/dev/null 2>&1 || \
 %install
 %make_install
 ln -sf /etc/smack/test_smack_rules %{buildroot}/etc/smack/test_smack_rules_lnk
+cp -a %{SOURCE1} %{buildroot}%{_datadir}/
 
 %post
 # Reload dbus daemon to apply newly installed configuration
@@ -79,7 +79,7 @@ systemctl reload dbus
 echo "security-tests postinst done ..."
 
 %files
-%manifest %{name}.manifest
+%manifest %{_datadir}/%{name}.manifest
 %defattr(-, root, root, -)
 /usr/bin/security-tests.sh
 /usr/bin/security-tests-all.sh