Apply Full RELRO linker options ("-Wl,-z,relro,-z,now") to tlm-sessiond
[platform/core/system/tlm.git] / src / sessiond / Makefile.am
index ab887f4..8a12e2a 100644 (file)
@@ -41,6 +41,11 @@ tlm_sessiond_CFLAGS = \
     -DG_LOG_DOMAIN=\"TLM_SESSIOND\" \
     $(NULL)
 
+# To apply Armoring(Full RELRO), where GOT Table becomes read-only.
+tlm_sessiond_LDFLAGS = \
+    -Wl,-z,relro,-z,now \
+    $(NULL)
+
 tlm_sessiond_LDADD = \
     libtlm-session-daemon.la \
     $(TLM_LIBS) \