Fix manifests
[platform/core/system/sync-agent.git] / packaging / sync-agent.spec
index fabbb31..8bf470f 100755 (executable)
@@ -6,7 +6,9 @@ Group:      System/Service
 URL:        http://www.tizen.org
 License:    Apache-2.0
 Source0:    sync-agent-%{version}.tar.gz
-Source1001:    sync-agent.manifest
+Source1001:    %{name}.manifest
+Source1002:    %{name}-devel.manifest
+Source1003:     common-public-plugins.manifest
 Requires(post): /sbin/ldconfig
 Requires(postun): /sbin/ldconfig
 BuildRequires:  pkgconfig(glib-2.0)
@@ -66,7 +68,7 @@ common public plugins for sync-agent
 
 %prep
 %setup -q
-cp %{SOURCE1001} .
+cp %{SOURCE1001} %{SOURCE1002} %{SOURCE1003} .
 
 
 %build
@@ -91,7 +93,7 @@ rm -rf %{buildroot}
 %{_libdir}/*.so.*
 
 %files devel
-%manifest %{name}.manifest
+%manifest %{name}-devel.manifest
 %defattr(-,root,root,-)
 %{_includedir}/sync_agent.h
 %{_includedir}/sync-agent/*
@@ -103,7 +105,7 @@ rm -rf %{buildroot}
 #/usr/lib/sync-agent/common-private/*
 
 %files -n common-public-plugins
-%manifest %{name}.manifest
+%manifest common-public-plugins.manifest
 %defattr(-,root,root,-)
 %{_libdir}/sync-agent/common-public/*