clean spec file for yocto compliance.
[platform/core/system/libslp-pm.git] / packaging / libslp-pm.spec
old mode 100644 (file)
new mode 100755 (executable)
index b6e46a2..6cbded5
@@ -1,68 +1,50 @@
-
 Name:       libslp-pm
 Summary:    Power manager library
 Version:    1.2.4
-Release:    2.1
-Group:      TO_BE/FILLED_IN
-License:    TO BE FILLED IN
+Release:    0
+Group:      System/Libraries
+License:    Apache-2.0
 Source0:    libslp-pm-%{version}.tar.bz2
-Patch0:     remove_tests.patch
-Requires(post): /sbin/ldconfig
-Requires(postun): /sbin/ldconfig
+Source1001: libslp-pm.manifest
 BuildRequires:  cmake
 
-
 %description
 Samsung Linux platform power manager client library
 
-
-
 %package devel
 Summary:    SLP power manager client (devel)
 Group:      Development/Libraries
 Requires:   %{name} = %{version}-%{release}
-Requires:   libslp-pm
 
 %description devel
 SLP power manager client library (devel)
 
-
 %prep
 %setup -q 
-%patch0 -p1
-
+cp %{SOURCE1001} .
 
 %build
-cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
-
-
-make %{?jobs:-j%jobs}
+%cmake .
+%__make %{?jobs:-j%jobs}
 
 %install
 rm -rf %{buildroot}
 %make_install
 
-
-
-
 %post -p /sbin/ldconfig
 
 %postun -p /sbin/ldconfig
 
-
-
-
-
 %files
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
-%doc COPYING
 %{_libdir}/libpmapi.so.1.2
 
-
 %files devel
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
 %{_includedir}/pmapi.h
+%{_includedir}/pmapi_managed.h
 %{_includedir}/SLP_pm_PG.h
 %{_libdir}/pkgconfig/pmapi.pc
 %{_libdir}/libpmapi.so
-