Add scheme encryption test db generator
[platform/core/security/key-manager.git] / packaging / key-manager.spec
index a545db1..a054ff6 100644 (file)
@@ -151,6 +151,9 @@ cp tests/XML_1_okay.xsd %{buildroot}/usr/share/ckm-db-test/
 cp tests/XML_1_wrong.xml %{buildroot}/usr/share/ckm-db-test/
 cp tests/XML_1_wrong.xsd %{buildroot}/usr/share/ckm-db-test/
 cp tests/XML_2_structure.xml %{buildroot}/usr/share/ckm-db-test/
+cp tests/encryption-scheme/db/db-7654 %{buildroot}/usr/share/ckm-db-test/db-7654
+cp tests/encryption-scheme/db/db-key-7654 %{buildroot}/usr/share/ckm-db-test/db-key-7654
+cp tests/encryption-scheme/db/key-7654 %{buildroot}/usr/share/ckm-db-test/key-7654
 
 %make_install
 %install_service multi-user.target.wants central-key-manager.service
@@ -289,5 +292,10 @@ fi
 %{_datadir}/ckm-db-test/XML_1_wrong.xml
 %{_datadir}/ckm-db-test/XML_1_wrong.xsd
 %{_datadir}/ckm-db-test/XML_2_structure.xml
+%{_datadir}/ckm-db-test/db-7654
+%{_datadir}/ckm-db-test/db-key-7654
+%{_datadir}/ckm-db-test/key-7654
+%{_datadir}/ckm-db-test/encryption-scheme.p12
 %{_bindir}/ckm_so_loader
 %{_bindir}/ckm_db_tool
+%{_bindir}/ckm_generate_db