Fixate video caps to remove negotiation failure
[platform/core/multimedia/libmm-camcorder.git] / packaging / libmm-camcorder.spec
index 2707df5..b247996 100644 (file)
@@ -1,8 +1,6 @@
-%bcond_with wayland
-
 Name:       libmm-camcorder
 Summary:    Camera and recorder library
-Version:    0.10.60
+Version:    0.10.139
 Release:    0
 Group:      Multimedia/Libraries
 License:    Apache-2.0
@@ -20,10 +18,6 @@ BuildRequires:  pkgconfig(mmutil-jpeg)
 BuildRequires:  pkgconfig(gstreamer-base-1.0)
 BuildRequires:  pkgconfig(gstreamer-video-1.0)
 BuildRequires:  pkgconfig(gstreamer-app-1.0)
-%if %{with wayland}
-BuildRequires:  pkgconfig(gstreamer-wayland-1.0)
-BuildRequires:  pkgconfig(wayland-client)
-%endif
 BuildRequires:  pkgconfig(vconf)
 BuildRequires:  pkgconfig(libtbm)
 BuildRequires:  pkgconfig(storage)
@@ -37,6 +31,7 @@ BuildRequires:  pkgconfig(aul)
 BuildRequires:  pkgconfig(ttrace)
 BuildRequires:  pkgconfig(libtzplatform-config)
 BuildRequires:  pkgconfig(dpm)
+BuildRequires:  pkgconfig(dlog)
 
 %description
 Camera and recorder function supported library.
@@ -57,15 +52,9 @@ Camera and recorder function supported library for development.
 
 
 %build
-%if %{with wayland}
-export CFLAGS+=" -DHAVE_WAYLAND -DGST_USE_UNSTABLE_API"
-%endif
-export CFLAGS+=" -D_LARGEFILE64_SOURCE -DSYSCONFDIR=\\\"%{_sysconfdir}\\\" -DTZ_SYS_ETC=\\\"%{TZ_SYS_ETC}\\\""
+export CFLAGS+=" -D_LARGEFILE64_SOURCE -DGST_USE_UNSTABLE_API -DSYSCONFDIR=\\\"%{_sysconfdir}\\\" -DTZ_SYS_ETC=\\\"%{TZ_SYS_ETC}\\\""
 ./autogen.sh
 %configure \
-%if %{with wayland}
-       --enable-wayland \
-%endif
 %if "%{TIZEN_PRODUCT_TV}" != "1"
        --enable-murphy \
 %else
@@ -76,8 +65,6 @@ export CFLAGS+=" -D_LARGEFILE64_SOURCE -DSYSCONFDIR=\\\"%{_sysconfdir}\\\" -DTZ_
 make %{?jobs:-j%jobs}
 
 %install
-mkdir -p %{buildroot}%{_datadir}/license
-cp LICENSE.APLv2 %{buildroot}%{_datadir}/license/%{name}
 %make_install
 
 
@@ -88,11 +75,10 @@ cp LICENSE.APLv2 %{buildroot}%{_datadir}/license/%{name}
 
 %files
 %manifest libmm-camcorder.manifest
+%license LICENSE.APLv2
 %defattr(-,root,root,-)
-%{_bindir}/*
 %{_libdir}/*.so.*
 %{_datadir}/sounds/mm-camcorder/*
-%{_datadir}/license/%{name}
 
 %files devel
 %defattr(-,root,root,-)