Change 'enable' method to async operation
[platform/core/connectivity/zigbee-manager.git] / packaging / zigbee-manager.spec
index 3f04f55..2082223 100644 (file)
@@ -9,6 +9,7 @@ License:        Apache-2.0
 Summary:        ZigBee Daemon
 Group:          System/Network
 Source0:        %{name}-%{version}.tar.gz
+Source1:        org.tizen.zigbee.service
 BuildRequires:  cmake
 BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(gio-2.0)
@@ -39,6 +40,9 @@ ZigBee library (devel)
 %prep
 %setup -q
 
+chmod 644 %{SOURCE1}
+cp -a %{SOURCE1} .
+
 %build
 cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DVERSION=%{version} \
 
@@ -48,9 +52,11 @@ make %{?_smp_mflags}
 
 %make_install
 
-# For debug, do not execute zigbee daemon automatically.
-#mkdir -p %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants
-#ln -s %{_libdir}/systemd/system/zigbee-daemon.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/zigbee-daemon.service
+mkdir -p %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants
+ln -s %{_libdir}/systemd/system/zigbee-daemon.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/zigbee-daemon.service
+
+mkdir -p %{buildroot}%{_datadir}/dbus-1/system-services/
+cp org.tizen.zigbee.service %{buildroot}%{_datadir}/dbus-1/system-services/org.tizen.zigbee.service
 
 %post -p /sbin/ldconfig
 
@@ -60,13 +66,12 @@ make %{?_smp_mflags}
 %manifest zigbee-daemon.manifest
 %defattr(644,system,system,-)
 %attr(755,system,system) %{_bindir}/zigbee-daemon
-# For debug, do not execute zigbee daemon automatically.
-#%{_libdir}/systemd/system/zigbee-daemon.service
-#%{_libdir}/systemd/system/multi-user.target.wants/zigbee-daemon.service
+%{_libdir}/systemd/system/zigbee-daemon.service
+%{_libdir}/systemd/system/multi-user.target.wants/zigbee-daemon.service
 %{_datadir}/license/zigbee-daemon
+%attr(644,root,root) %{_datadir}/dbus-1/system-services/*
 
 %files -n zigbee-lib
-#%manifest lib-zigbee/lib-zigbee.manifest
 %defattr(644,system,system,-)
 %{_libdir}/libzigbee-lib.so*
 %{_datadir}/license/zigbee-lib