Remove gcov rpm package
[platform/core/connectivity/smartcard-service.git] / packaging / smartcard-service.spec
index ab1a2e2..4a9ab34 100755 (executable)
@@ -1,10 +1,11 @@
 Name:       smartcard-service
 Summary:    Smartcard Service FW
-Version:    0.1.58
+Version:    0.1.59
 Release:    0
 Group:      Network & Connectivity
 License:    Apache-2.0
 Source0:    %{name}-%{version}.tar.gz
+Source1:    smartcard-service.service
 BuildRequires: cmake
 BuildRequires: pkgconfig(glib-2.0)
 BuildRequires: pkgconfig(gio-unix-2.0)
@@ -54,18 +55,14 @@ common smartcard service.
 
 
 %build
-%if 0%{?gcov:1}
-export CFLAGS+=" -fprofile-arcs -ftest-coverage"
-export CXXFLAGS+=" -fprofile-arcs -ftest-coverage"
-export LDFLAGS+=" -lgcov "
-%endif
-
-%cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DBUILD_GTESTS=%{?gtests:1}%{!?gtests:0} \
-                                       -DBUILD_GCOV=%{?gcov:1}%{!?gcov:0}
+%cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} -DBUILD_GTESTS=%{?gtests:1}%{!?gtests:0}
 
 %install
 %make_install
 
+mkdir -p %{buildroot}/usr/lib/systemd/system/
+cp -af %{SOURCE1} %{buildroot}/usr/lib/systemd/system/
+
 mkdir -p %{buildroot}/etc/dbus-1/system.d/
 cp -af %{_builddir}/%{name}-%{version}/packaging/org.tizen.SmartcardService.conf %{buildroot}/etc/dbus-1/system.d/
 
@@ -75,6 +72,7 @@ cp -af %{_builddir}/%{name}-%{version}/packaging/org.tizen.SmartcardService.conf
 %{_bindir}/smartcard-daemon
 %{_sysconfdir}/dbus-1/system.d/org.tizen.SmartcardService.conf
 %{_datadir}/dbus-1/system-services/org.tizen.SmartcardService.service
+/usr/lib/systemd/system/%{name}.service
 %if 0%{?gtests:1}
 %{_bindir}/gtest*
 %endif