Add the scripts for IVI profile
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
index d10eb11..c8a4ade 100644 (file)
@@ -1,6 +1,6 @@
 Name:       bluetooth-tools
 Summary:    Bluetooth-tools
-Version:    0.2.36
+Version:    0.2.37
 Release:    0
 Group:      Network & Connectivity/Bluetooth
 License:    Apache-2.0
@@ -45,13 +45,22 @@ export CFLAGS="$CFLAGS -DTIZEN_WEARABLE"
 %if "%{profile}" == "mobile"
        -DTIZEN_MOBILE=YES \
        -DTIZEN_WEARABLE=NO \
+       -DTIZEN_IVI=NO \
 %else
 %if "%{profile}" == "wearable"
        -DTIZEN_MOBILE=NO \
         -DTIZEN_WEARABLE=YES \
+       -DTIZEN_IVI=NO \
 %else
+%if "%{profile}" == "ivi"
         -DTIZEN_MOBILE=NO \
         -DTIZEN_WEARABLE=NO \
+       -DTIZEN_IVI=YES \
+%else
+        -DTIZEN_MOBILE=NO \
+        -DTIZEN_WEARABLE=NO \
+       -DTIZEN_IVI=NO \
+%endif
 %endif
 %endif
 
@@ -81,7 +90,7 @@ install -D -m 0644 LICENSE.APLv2 %{buildroot}%{_datadir}/license/bluetooth-tools
 %files
 %manifest %{name}.manifest
 %defattr(-,root,root,-)
-%if "%{profile}" == "mobile" || "%{profile}" == "wearable"
+%if "%{profile}" == "mobile" || "%{profile}" == "wearable" || "%{profile}" == "ivi"
 %exclude %{_sysconfdir}/rc.d/init.d/bluetooth-address
 %else
 %{_sysconfdir}/rc.d/init.d/bluetooth-address