Add the service files to run bt-stack-down*.sh via file activation
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
index 1f051b4..79ccf1e 100644 (file)
@@ -97,40 +97,40 @@ install -D -m 0644 packaging/bluetooth-hci-logger.path %{buildroot}%{_libdir}/sy
 install -D -m 0644 packaging/bluetooth-hci-logger-stop.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger-stop.service
 install -D -m 0644 packaging/bluetooth-hci-logger-stop.path %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-logger-stop.path
 
-install -D -m 0644 packaging/bluetooth-rfkill-unblock.service %{buildroot}%{_libdir}/systemd/system/bluetooth-rfkill-unblock.service
-install -D -m 0644 packaging/bluetooth-rfkill-unblock.path %{buildroot}%{_libdir}/systemd/system/bluetooth-rfkill-unblock.path
-
-install -D -m 0644 packaging/bluetooth-rfkill-block.service %{buildroot}%{_libdir}/systemd/system/bluetooth-rfkill-block.service
-install -D -m 0644 packaging/bluetooth-rfkill-block.path %{buildroot}%{_libdir}/systemd/system/bluetooth-rfkill-block.path
-
 install -D -m 0644 packaging/bluez-start.service %{buildroot}%{_libdir}/systemd/system/bluez-start.service
 install -D -m 0644 packaging/bluez-start.path %{buildroot}%{_libdir}/systemd/system/bluez-start.path
 
 install -D -m 0644 packaging/bluetooth-share-start.service %{buildroot}%{_libdir}/systemd/system/bluetooth-share-start.service
 install -D -m 0644 packaging/bluetooth-share-start.path %{buildroot}%{_libdir}/systemd/system/bluetooth-share-start.path
 
+install -D -m 0644 packaging/bluetooth-stack-down.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down.service
+install -D -m 0644 packaging/bluetooth-stack-down.path %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down.path
+
 install -D -m 0644 packaging/bluetooth-force-hci-logger.service %{buildroot}%{_libdir}/systemd/system/bluetooth-force-hci-logger.service
 install -D -m 0644 packaging/bluetooth-hci-dump@.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-dump@.service
 
 %post
 mkdir -p %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
+mkdir -p %{_libdir}/systemd/system/multi-user.target.wants/
 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hci-logger.path
-
-ln -sf %{_libdir}/systemd/system/bluetooth-rfkill-unblock.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
-ln -sf %{_libdir}/systemd/system/bluetooth-rfkill-unblock.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-rfkill-unblock.path
-
-ln -sf %{_libdir}/systemd/system/bluetooth-rfkill-block.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
-ln -sf %{_libdir}/systemd/system/bluetooth-rfkill-block.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-rfkill-block.path
+ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger.path %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
 
 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger-stop.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
 ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger-stop.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hci-logger-stop.path
+ln -sf %{_libdir}/systemd/system/bluetooth-hci-logger-stop.path %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
 
 ln -sf %{_libdir}/systemd/system/bluez-start.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
 ln -sf %{_libdir}/systemd/system/bluez-start.path %{_libdir}/systemd/system/multi-user.target.wants/bluez-start.path
+ln -sf %{_libdir}/systemd/system/bluez-start.path %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
 
 ln -sf %{_libdir}/systemd/system/bluetooth-share-start.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
 ln -sf %{_libdir}/systemd/system/bluetooth-share-start.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-share-start.path
+ln -sf %{_libdir}/systemd/system/bluetooth-share-start.path %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
+
+ln -sf %{_libdir}/systemd/system/bluetooth-stack-down.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
+ln -sf %{_libdir}/systemd/system/bluetooth-stack-down.path %{_libdir}/systemd/system/multi-user.target.wants/bluetooth-stack-down.path
+ln -sf %{_libdir}/systemd/system/bluetooth-stack-down.path %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
 
 ln -sf %{_libdir}/systemd/system/bluetooth-force-hci-logger.service %{_sysconfdir}/systemd/default-extra-dependencies/ignore-units.d/
 
@@ -152,10 +152,6 @@ ln -sf %{_libdir}/systemd/system/bluetooth-force-hci-logger.service %{_sysconfdi
 #%{_unitdir}/bluetooth-address.service
 %{_libdir}/systemd/system/bluetooth-hci-logger.service
 %{_libdir}/systemd/system/bluetooth-hci-logger.path
-%{_libdir}/systemd/system/bluetooth-rfkill-unblock.service
-%{_libdir}/systemd/system/bluetooth-rfkill-unblock.path
-%{_libdir}/systemd/system/bluetooth-rfkill-block.service
-%{_libdir}/systemd/system/bluetooth-rfkill-block.path
 %{_libdir}/systemd/system/bluetooth-hci-logger-stop.service
 %{_libdir}/systemd/system/bluetooth-hci-logger-stop.path
 %{_libdir}/systemd/system/bluez-start.service
@@ -164,6 +160,8 @@ ln -sf %{_libdir}/systemd/system/bluetooth-force-hci-logger.service %{_sysconfdi
 %{_libdir}/systemd/system/bluetooth-share-start.path
 %{_libdir}/systemd/system/bluetooth-force-hci-logger.service
 %{_libdir}/systemd/system/bluetooth-hci-dump@.service
+%{_libdir}/systemd/system/bluetooth-stack-down.service
+%{_libdir}/systemd/system/bluetooth-stack-down.path
 
 %post profile_common
 pushd %{_prefix}/etc/bluetooth/