Fix the service file overwriting issue on the common profile
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
index c38982b..52605b5 100644 (file)
@@ -115,26 +115,10 @@ mkdir -p %{_libdir}/systemd/system/multi-user.target.wants/
 %manifest %{name}.manifest
 %license LICENSE.APLv2
 %defattr(-,root,root,-)
-#%exclude %{_sysconfdir}/rc.d/init.d/bluetooth-address
-#%{_sysconfdir}/rc.d/rc3.d/S60bluetooth-address
-#%{_sysconfdir}/rc.d/rc5.d/S60bluetooth-address
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-on.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-dev-up.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-mode-on.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-off.sh
-#%attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-hci-logdump.sh
-#%attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-run-hci-logger.sh
-#%{_unitdir}/multi-user.target.wants/bluetooth-address.service
-#%{_unitdir}/bluetooth-address.service
-#%{_libdir}/systemd/system/bluetooth-hci-logger.service
-#%{_libdir}/systemd/system/bluetooth-hci-logger-stop.service
-%{_libdir}/systemd/system/bluez-start.service
-#%{_libdir}/systemd/system/bluetooth-force-hci-logger.service
-#%{_libdir}/systemd/system/bluetooth-hci-dump@.service
-%{_libdir}/systemd/system/bluetooth-stack-up.service
-%{_libdir}/systemd/system/bluetooth-stack-down.service
-%{_libdir}/systemd/system/bluetooth-hci-up.service
-%{_libdir}/systemd/system/bluetooth-hci-down.service
 
 %post profile_common
 pushd %{_prefix}/etc/bluetooth/
@@ -186,6 +170,11 @@ popd
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-reset-env.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down-with-radio.sh
 %{_libdir}/systemd/system/bluetooth-stack-down-with-radio.service
+%{_libdir}/systemd/system/bluez-start.service
+%{_libdir}/systemd/system/bluetooth-stack-up.service
+%{_libdir}/systemd/system/bluetooth-stack-down.service
+%{_libdir}/systemd/system/bluetooth-hci-up.service
+%{_libdir}/systemd/system/bluetooth-hci-down.service
 
 %post profile_ivi
 pushd %{_prefix}/etc/bluetooth/
@@ -204,6 +193,11 @@ popd
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-up.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-down.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-reset-env.sh
+%{_libdir}/systemd/system/bluez-start.service
+%{_libdir}/systemd/system/bluetooth-stack-up.service
+%{_libdir}/systemd/system/bluetooth-stack-down.service
+%{_libdir}/systemd/system/bluetooth-hci-up.service
+%{_libdir}/systemd/system/bluetooth-hci-down.service
 
 %post profile_wearable
 pushd %{_prefix}/etc/bluetooth/
@@ -222,6 +216,11 @@ popd
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-up.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-down.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-reset-env.sh
+%{_libdir}/systemd/system/bluez-start.service
+%{_libdir}/systemd/system/bluetooth-stack-up.service
+%{_libdir}/systemd/system/bluetooth-stack-down.service
+%{_libdir}/systemd/system/bluetooth-hci-up.service
+%{_libdir}/systemd/system/bluetooth-hci-down.service
 
 %files no-firmware
 %manifest %{name}.manifest
@@ -229,3 +228,9 @@ popd
 %defattr(-, root, root)
 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start.sh
+%{_libdir}/systemd/system/bluez-start.service
+%{_libdir}/systemd/system/bluetooth-stack-up.service
+%{_libdir}/systemd/system/bluetooth-stack-down.service
+%{_libdir}/systemd/system/bluetooth-hci-up.service
+%{_libdir}/systemd/system/bluetooth-hci-down.service
+