Fix the service file overwriting issue on the common profile
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
index 1e3846d..52605b5 100644 (file)
@@ -5,7 +5,7 @@ Release:    0
 Group:      Network & Connectivity/Bluetooth
 License:    Apache-2.0
 Source0:    %{name}-%{version}.tar.gz
-Source1001: bluetooth-address.service
+#Source1001: bluetooth-address.service
 BuildRequires:  cmake
 Suggests:       bluetooth-share
 Requires:       tizen-platform-config-tools
@@ -73,42 +73,52 @@ export CXXFLAGS+=" -fpie -fvisibility=hidden"
 export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=ignore-in-shared-libs -pie"
 
 %cmake
-%cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix}
+%cmake . -DCMAKE_INSTALL_PREFIX=%{_prefix} \
+%if 0%{?tizen_build_binary_release_type_eng}
+       -DBT_HCI_LOG_SIZE=10
+%else
+       -DBT_HCI_LOG_SIZE=5
+%endif
+
 %__make %{?_smp_mflags}
 
 %install
 rm -rf %{buildroot}
 %make_install
 
-mkdir -p %{buildroot}%{_sysconfdir}/rc.d/rc3.d
-mkdir -p %{buildroot}%{_sysconfdir}/rc.d/rc5.d
-ln -s %{_sysconfdir}/rc.d/init.d/bluetooth-address %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S60bluetooth-address
-ln -s %{_sysconfdir}/rc.d/init.d/bluetooth-address %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S60bluetooth-address
-
-mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants
-install -m 0644 %{SOURCE1001} %{buildroot}%{_unitdir}
-ln -s ../bluetooth-address.service %{buildroot}%{_unitdir}/multi-user.target.wants/bluetooth-address.service
-
 mkdir -p %{buildroot}%{_prefix}/etc/bluetooth/
+mkdir -p %{buildroot}/run/bluetooth
 install -m 0755 scripts/bt-dev-start.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-start.sh
 install -m 0755 scripts/bt-dev-end.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-end.sh
-install -D -m 0644 LICENSE.APLv2 %{buildroot}%{_datadir}/license/bluetooth-tools
+
+install -D -m 0644 packaging/bluez-start.service %{buildroot}%{_libdir}/systemd/system/bluez-start.service
+
+install -D -m 0644 packaging/bluetooth-stack-up.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-up.service
+
+install -D -m 0644 packaging/bluetooth-stack-down.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down.service
+
+install -D -m 0644 packaging/bluetooth-stack-down-with-radio.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down-with-radio.service
+
+#install -D -m 0644 packaging/bluetooth-force-hci-logger.service %{buildroot}%{_libdir}/systemd/system/bluetooth-force-hci-logger.service
+#install -D -m 0644 packaging/bluetooth-hci-dump@.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-dump@.service
+
+install -D -m 0644 packaging/bluetooth-hci-up.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-up.service
+install -D -m 0644 packaging/bluetooth-hci-down.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hci-down.service
+
+install -D -m 0644 packaging/bluetooth-stack-up-common.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-up-common.service
+install -D -m 0644 packaging/bluetooth-stack-down-common.service %{buildroot}%{_libdir}/systemd/system/bluetooth-stack-down-common.service
+
+%post
+mkdir -p %{_libdir}/systemd/system/multi-user.target.wants/
 
 %files
 %manifest %{name}.manifest
+%license LICENSE.APLv2
 %defattr(-,root,root,-)
-%exclude %{_sysconfdir}/rc.d/init.d/bluetooth-address
-%{_sysconfdir}/rc.d/rc3.d/S60bluetooth-address
-%{_sysconfdir}/rc.d/rc5.d/S60bluetooth-address
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-on.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-dev-up.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-mode-on.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-off.sh
-%attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-hci-logdump.sh
-%attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-run-hcidump.sh
-%{_datadir}/license/bluetooth-tools
-%{_unitdir}/multi-user.target.wants/bluetooth-address.service
-%{_unitdir}/bluetooth-address.service
 
 %post profile_common
 pushd %{_prefix}/etc/bluetooth/
@@ -116,17 +126,28 @@ ln -sf common/bt-stack-up.sh bt-stack-up.sh
 ln -sf common/bt-stack-down.sh bt-stack-down.sh
 ln -sf common/bt-reset-env.sh bt-reset-env.sh
 popd
+pushd %{_unitdir}
+mv bluetooth-stack-up-common.service bluetooth-stack-up.service
+mv bluetooth-stack-down-common.service bluetooth-stack-down.service
+popd
 %preun profile_common
 pushd %{_prefix}/etc/bluetooth/
 rm bt-stack-up.sh
 rm bt-stack-down.sh
 rm bt-reset-env.sh
 popd
+pushd %{_unitdir}
+rm bluetooth-stack-up.service
+rm bluetooth-stack-down.service
+popd
 %files profile_common
-%{_sysconfdir}/rc.d/init.d/bluetooth-address
+%license LICENSE.APLv2
+#%{_sysconfdir}/rc.d/init.d/bluetooth-address
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-up.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-stack-down.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/common/bt-reset-env.sh
+%{_libdir}/systemd/system/bluetooth-stack-up-common.service
+%{_libdir}/systemd/system/bluetooth-stack-down-common.service
 
 %post profile_mobile
 pushd %{_prefix}/etc/bluetooth/
@@ -143,10 +164,17 @@ rm bt-stack-down-with-radio.sh
 rm bt-reset-env.sh
 popd
 %files profile_mobile
+%license LICENSE.APLv2
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-up.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-reset-env.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/mobile/bt-stack-down-with-radio.sh
+%{_libdir}/systemd/system/bluetooth-stack-down-with-radio.service
+%{_libdir}/systemd/system/bluez-start.service
+%{_libdir}/systemd/system/bluetooth-stack-up.service
+%{_libdir}/systemd/system/bluetooth-stack-down.service
+%{_libdir}/systemd/system/bluetooth-hci-up.service
+%{_libdir}/systemd/system/bluetooth-hci-down.service
 
 %post profile_ivi
 pushd %{_prefix}/etc/bluetooth/
@@ -161,9 +189,15 @@ rm bt-stack-down.sh
 rm bt-reset-env.sh
 popd
 %files profile_ivi
+%license LICENSE.APLv2
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-up.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-stack-down.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/ivi/bt-reset-env.sh
+%{_libdir}/systemd/system/bluez-start.service
+%{_libdir}/systemd/system/bluetooth-stack-up.service
+%{_libdir}/systemd/system/bluetooth-stack-down.service
+%{_libdir}/systemd/system/bluetooth-hci-up.service
+%{_libdir}/systemd/system/bluetooth-hci-down.service
 
 %post profile_wearable
 pushd %{_prefix}/etc/bluetooth/
@@ -178,12 +212,25 @@ rm bt-stack-down.sh
 rm bt-reset-env.sh
 popd
 %files profile_wearable
+%license LICENSE.APLv2
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-up.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-stack-down.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/wearable/bt-reset-env.sh
+%{_libdir}/systemd/system/bluez-start.service
+%{_libdir}/systemd/system/bluetooth-stack-up.service
+%{_libdir}/systemd/system/bluetooth-stack-down.service
+%{_libdir}/systemd/system/bluetooth-hci-up.service
+%{_libdir}/systemd/system/bluetooth-hci-down.service
 
 %files no-firmware
 %manifest %{name}.manifest
+%license LICENSE.APLv2
 %defattr(-, root, root)
 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
 %attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start.sh
+%{_libdir}/systemd/system/bluez-start.service
+%{_libdir}/systemd/system/bluetooth-stack-up.service
+%{_libdir}/systemd/system/bluetooth-stack-down.service
+%{_libdir}/systemd/system/bluetooth-hci-up.service
+%{_libdir}/systemd/system/bluetooth-hci-down.service
+