Add no-firmware subpackage.
[platform/core/connectivity/bluetooth-tools.git] / packaging / bluetooth-tools.spec
index 6aebbae..3accaf2 100644 (file)
@@ -1,16 +1,26 @@
 Name:       bluetooth-tools
-Summary:    bluetooth-tools
+Summary:    Bluetooth-tools
 Version:    0.2.35
 Release:    3
-Group:      TO_BE/FILLED_IN
-License:    Apache License, Version 2.0
+Group:      Network & Connectivity/Bluetooth
+License:    Apache-2.0
 Source0:    %{name}-%{version}.tar.gz
 Source1001:    bluetooth-address.service
 BuildRequires:  cmake
+Requires : bluetooth-tools-no-firmware
 
 %description
 Tools fo bluetooth run/stop and set address
 
+%package no-firmware
+Summary:    On/Off Bluetooth adapter
+Group:      Network & Connectivity/Bluetooth
+Requires:   %{name} = %{version}-%{release}
+Requires: rfkill
+Conflicts:  bluetooth-firmware-bcm
+
+%description no-firmware
+On/Off bluetooth device
 
 %prep
 %setup -q
@@ -31,13 +41,16 @@ mkdir -p %{buildroot}%{_sysconfdir}/rc.d/rc5.d
 ln -s %{_sysconfdir}/rc.d/init.d/bluetooth-address %{buildroot}%{_sysconfdir}/rc.d/rc3.d/S60bluetooth-address
 ln -s %{_sysconfdir}/rc.d/init.d/bluetooth-address %{buildroot}%{_sysconfdir}/rc.d/rc5.d/S60bluetooth-address
 
-mkdir -p %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants
-install -m 0644 %{SOURCE1001} %{buildroot}%{_libdir}/systemd/system/
-ln -s ../bluetooth-address.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/bluetooth-address.service
+mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants
+install -m 0644 %{SOURCE1001} %{buildroot}%{_unitdir}
+ln -s ../bluetooth-address.service %{buildroot}%{_unitdir}/multi-user.target.wants/bluetooth-address.service
 
+mkdir -p %{buildroot}%{_prefix}/etc/bluetooth/
+install -m 0755 scripts/bt-dev-start.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-start.sh
+install -m 0755 scripts/bt-dev-end.sh %{buildroot}%{_prefix}/etc/bluetooth/bt-dev-end.sh
 
 %files
-%manifest bluetooth-tools.manifest
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
 %{_sysconfdir}/rc.d/init.d/bluetooth-address
 %{_sysconfdir}/rc.d/rc3.d/S60bluetooth-address
@@ -49,6 +62,12 @@ ln -s ../bluetooth-address.service %{buildroot}%{_libdir}/systemd/system/multi-u
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-dev-up.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-mode-on.sh
 %attr(0755,-,-) %{_prefix}/etc/bluetooth/bt-edutm-off.sh
-%{_libdir}/systemd/system/multi-user.target.wants/bluetooth-address.service
-%{_libdir}/systemd/system/bluetooth-address.service
 
+%{_unitdir}/multi-user.target.wants/bluetooth-address.service
+%{_unitdir}/bluetooth-address.service
+
+%files no-firmware
+%manifest %{name}.manifest
+%defattr(-, root, root)
+%attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-end.sh
+%attr(755,-,-) %{_prefix}/etc/bluetooth/bt-dev-start.sh