Refactory the packages for each functionality
[platform/core/connectivity/bluetooth-agent.git] / packaging / bluetooth-agent.spec
index 599db73..9c80b8e 100644 (file)
@@ -45,45 +45,53 @@ BuildRequires:  pkgconfig(libexif)
 BuildRequires:  pkgconfig(gio-2.0)
 BuildRequires:  cmake
 Requires: security-config
-Requires:      %{name}-compat = %{version}-%{release}
-Recommends:    %{name}-profile_common = %{version}-%{release}
+#Requires:     %{name}-compat = %{version}-%{release}
+#Recommends:   %{name}-profile_common = %{version}-%{release}
 
 %description
 Bluetooth agent packages that support various external profiles
 
-%package profile_common
-Summary:       Bluetooth agent for common/tv/mobile
-Provides:      %{name}-compat = %{version}-%{release}
-Provides:      %{name}-profile_mobile = %{version}-%{release}
-Provides:      %{name}-profile_tv = %{version}-%{release}
-Conflicts:     %{name}-profile_ivi
-Conflicts:     %{name}-profile_wearable
-%description profile_common
-Bluetooth agent binary compiled for common, tv, mobile profiles
-
-%package profile_ivi
-Summary:       Bluetooth agent for ivi
-Provides:      %{name}-compat = %{version}-%{release}
-Conflicts:     %{name}-profile_common
-Conflicts:     %{name}-profile_wearable
-%description profile_ivi
-Bluetooth agent binary compiled for ivi profile
-
-%package profile_wearable
-Summary:       Bluetooth agent for wearable
-Provides:      %{name}-compat = %{version}-%{release}
-Conflicts:     %{name}-profile_common
-Conflicts:     %{name}-profile_ivi
-%description profile_wearable
-Bluetooth agent binary compiled for wearable profile
+%package hfp_ag
+Summary:       Bluetooth agent for HFP(Hands-Free Profile)'s AG(Audio Gate) role
+Requires:   %{name} = %{version}-%{release}
+Group:      Network & Connectivity/Bluetooth
+%description hfp_ag
+Bluetooth agent binary compiled for HFP(Hands-Free Profile)'s AG(Audio Gate) role
 
-%package ipsp
-Summary:    Bluetooth Ipsp daemon
+%package hfp_hf
+Summary:       Bluetooth agent for HFP(Hands-Free Profile)'s HF(Hands-Free) role
+Requires:   %{name} = %{version}-%{release}
 Group:      Network & Connectivity/Bluetooth
+%description hfp_hf
+Bluetooth agent binary compiled for HFP(Hands-Free Profile)'s HF(Hands-Free) role
+
+%package map
+Summary:       Bluetooth agent for MAP(Message Access Profile) server
 Requires:   %{name} = %{version}-%{release}
+Group:      Network & Connectivity/Bluetooth
+%description map
+Bluetooth agent binary compiled for MAP(Message Access Profile) server
 
+%package pbap
+Summary:       Bluetooth agent for PBAP(PhoneBook Access Profile) server
+Requires:   %{name} = %{version}-%{release}
+Group:      Network & Connectivity/Bluetooth
+%description pbap
+Bluetooth agent binary compiled for PBAP(PhoneBook Access Profile) server
+
+%package hid
+Summary:       Bluetooth agent for HID(Human Interface Device)'s device role
+Requires:   %{name} = %{version}-%{release}
+Group:      Network & Connectivity/Bluetooth
+%description hid
+Bluetooth agent binary compiled for HID(Human Interface Device)'s device role
+
+%package ipsp
+Summary:       Bluetooth agent for IPSP(Internet Protocol Support Profile)
+Requires:   %{name} = %{version}-%{release}
+Group:      Network & Connectivity/Bluetooth
 %description ipsp
-This package is Bluetooth ipsp daemon to manage activation / deactivation.
+Bluetooth agent binary compiled for IPSP(Internet Protocol Support Profile)
 
 %prep
 %setup -q
@@ -133,9 +141,9 @@ install -D -m 0644 packaging/bluetooth-map-agent.service %{buildroot}%{_libdir}/
 #mkdir -p %{buildroot}%{_datadir}/dbus-1/system-services
 #mkdir -p %{buildroot}%{_bindir}/
 #install -D -m 0644 %{buildroot}/usr/share/dbus-1/system-services/org.bluez.hf_agent.service %{buildroot}%{_datadir}/dbus-1/system-services/
-#install -D -m 0644 %{buildroot}/usr/share/dbus-1/system-services/org.projectx.bt_ipsp.service %{buildroot}%{_datadir}/dbus-1/system-services/
+#install -D -m 0644 %{buildroot}/usr/share/dbus-1/system-services/org.bluez.ipsp_agent.service %{buildroot}%{_datadir}/dbus-1/system-services/
 #install -D -m 0644 %{buildroot}/usr/bin/bluetooth-hf-agent %{buildroot}%{_bindir}/
-#install -D -m 0644 %{buildroot}/usr/bin/bt-ipsp %{buildroot}%{_bindir}/
+#install -D -m 0644 %{buildroot}/usr/bin/bluetooth-ipsp-agent %{buildroot}%{_bindir}/
 #%endif
 install -D -m 0644 packaging/bluetooth-pbap-agent.service %{buildroot}%{_libdir}/systemd/system/bluetooth-pbap-agent.service
 
@@ -150,51 +158,49 @@ ln -sf %{_libdir}/systemd/system/bluetooth-pbap-agent.service %{_sysconfdir}/sys
 %license LICENSE
 %defattr(-, root, root)
 
-# This usage of profile macro does NOT conflict 4.0 configurability.
-%if "%{?profile}" != "mobile" && "%{?profile}" != "tv"
-# Original: wearable, ivi. Added: common, "undefined"
-%files profile_wearable
+%files hfp_ag
+%manifest %{name}.manifest
 %license LICENSE
-%{_bindir}/bluetooth-hf-agent
 %{_bindir}/bluetooth-ag-agent
-%{_bindir}/bluetooth-hid-agent
-%{_datadir}/dbus-1/system-services/org.bluez.hf_agent.service
+%attr(0666,-,-) /var/lib/bluetooth/voice-recognition-blacklist
 %{_datadir}/dbus-1/system-services/org.bluez.ag_agent.service
-%{_datadir}/dbus-1/system-services/org.bluez.hid_agent.service
 %{_sysconfdir}/dbus-1/system.d/bluetooth-ag-agent.conf
-%{_sysconfdir}/dbus-1/system.d/bluetooth-hf-agent.conf
-%exclude %{_libdir}/systemd/system/bluetooth-map-agent.service
-%exclude %{_libdir}/systemd/system/bluetooth-pbap-agent.service
-%endif
+#%exclude %{_libdir}/systemd/system/bluetooth-map-agent.service
+#%exclude %{_libdir}/systemd/system/bluetooth-pbap-agent.service
 
-%files profile_ivi
+%files hfp_hf
+%manifest %{name}.manifest
 %license LICENSE
 %{_bindir}/bluetooth-hf-agent
 %{_datadir}/dbus-1/system-services/org.bluez.hf_agent.service
-%exclude %{_libdir}/systemd/system/bluetooth-map-agent.service
-%exclude %{_libdir}/systemd/system/bluetooth-pbap-agent.service
+%{_sysconfdir}/dbus-1/system.d/bluetooth-hf-agent.conf
+#%exclude %{_libdir}/systemd/system/bluetooth-map-agent.service
+#%exclude %{_libdir}/systemd/system/bluetooth-pbap-agent.service
 
-# This usage of profile macro does NOT conflict 4.0 configurability.
-%if "%{?profile}" != "wearable" && "%{?profile}" != "ivi"
-# Original: common, mobile, tv. Added: "undefined"
-%files profile_common
+%files map
+%manifest %{name}.manifest
 %license LICENSE
-%{_bindir}/bluetooth-ag-agent
 %{_bindir}/bluetooth-map-agent
-%{_bindir}/bluetooth-pb-agent
-%{_datadir}/dbus-1/system-services/org.bluez.pb_agent.service
 %{_datadir}/dbus-1/system-services/org.bluez.map_agent.service
-%{_datadir}/dbus-1/system-services/org.bluez.ag_agent.service
-%attr(0666,-,-) /var/lib/bluetooth/voice-recognition-blacklist
-%{_sysconfdir}/dbus-1/system.d/bluetooth-ag-agent.conf
 %{_libdir}/systemd/system/bluetooth-map-agent.service
+
+%files pbap
+%manifest %{name}.manifest
+%license LICENSE
+%{_bindir}/bluetooth-pb-agent
+%{_datadir}/dbus-1/system-services/org.bluez.pb_agent.service
 %{_libdir}/systemd/system/bluetooth-pbap-agent.service
-%endif
+
+%files hid
+%manifest %{name}.manifest
+%license LICENSE
+%{_bindir}/bluetooth-hid-agent
+%{_datadir}/dbus-1/system-services/org.bluez.hid_agent.service
 
 %files ipsp
 %manifest %{name}.manifest
 %license LICENSE
-%defattr(-, root, root)
-%{_datadir}/dbus-1/system-services/org.projectx.bt_ipsp.service
-%{_bindir}/bt-ipsp
-%{_sysconfdir}/dbus-1/system.d/bluetooth-frwk-ipsp.conf
+%{_bindir}/bluetooth-ipsp-agent
+%{_datadir}/dbus-1/system-services/org.bluez.ipsp_agent.service
+%{_sysconfdir}/dbus-1/system.d/bluetooth-ipsp-agent.conf
+