Fix the ASAN build error
[platform/core/connectivity/bluetooth-agent.git] / packaging / bluetooth-agent.spec
index 9852a3e..82ab05e 100644 (file)
@@ -158,18 +158,6 @@ find . -name '*.gcno' -exec cp '{}' gcov-obj ';'
 rm -rf %{buildroot}
 %make_install
 
-%if 0%{?gcov:1}
-mkdir -p %{buildroot}%{_datadir}/gcov/obj
-install -m 0644 gcov-obj/* %{buildroot}%{_datadir}/gcov/obj
-%endif
-
-%check
-%if 0%{?gcov:1}
-pushd unittest
-./run_coverage.sh
-popd
-%endif
-
 # This usage of profile macro does NOT conflict 4.0 configurability.
 #%if "%{?profile}" != "mobile" && "%{?profile}" != "tv"
 # Original: wearable, ivi. Added: common, "undefined"
@@ -186,6 +174,18 @@ install -D -m 0644 packaging/bluetooth-ag-agent.service %{buildroot}%{_unitdir}/
 install -D -m 0644 packaging/bluetooth-hf-agent.service %{buildroot}%{_unitdir}/bluetooth-hf-agent.service
 install -D -m 0644 packaging/bluetooth-hid-agent.service %{buildroot}%{_unitdir}/bluetooth-hid-agent.service
 
+%if 0%{?gcov:1}
+mkdir -p %{buildroot}%{_datadir}/gcov/obj
+install -m 0644 gcov-obj/* %{buildroot}%{_datadir}/gcov/obj
+%endif
+
+%check
+%if 0%{?gcov:1}
+pushd unittest
+./run_coverage.sh
+popd
+%endif
+
 %files
 %manifest %{name}.manifest
 %license LICENSE