fix build error on building gcov mode
[platform/core/connectivity/bluetooth-agent.git] / packaging / bluetooth-agent.spec
index 51e7dbf..81ec62f 100644 (file)
@@ -141,7 +141,7 @@ export LDFLAGS+=" -Wl,--rpath=/usr/lib -Wl,--as-needed -Wl,--unresolved-symbols=
 export CFLAGS_DEFAULT="$CFLAGS"
 
 # Build All (wearalbe/ivi/common/tv/mobile)
-cmake . -DCMAKE_INSTALL_PREFIX=/usr \
+%cmake . -DCMAKE_INSTALL_PREFIX=/usr \
        -DTIZEN_FEATURE_BT_HFP_AG=1 \
        -DBUILD_GTESTS=%{?gcov:1}%{!?gcov:0} \
        -DBUILD_GCOV=%{?gcov:1}%{!?gcov:0}
@@ -230,6 +230,4 @@ ln -sf %{_libdir}/systemd/system/bluetooth-pbap-agent.service %{_sysconfdir}/sys
 %manifest %{name}.manifest
 %{_bindir}/gtest-bluetooth-agent
 %{_libdir}/lib*
-%exclude %{_libdir}/debug/*
-%exclude %{_libdir}/debug/.build-id/*
 %endif