fhub: Apply lastest FHUB4.0 bluetooth-agent
[platform/core/connectivity/bluetooth-agent.git] / packaging / bluetooth-agent.spec
index f6c36e0..81da085 100644 (file)
@@ -11,6 +11,7 @@ Source1001:   bluetooth-agent.manifest
 
 BuildRequires:  pkgconfig(aul)
 BuildRequires:  pkgconfig(bluetooth-api)
+BuildRequires:  pkgconfig(capi-media-audio-io)
 
 # The profile macro usage with the following comments may be removed after
 # Tizen OBS build projects are merged. However, each vendor may keep using
@@ -98,6 +99,12 @@ Group:      Network & Connectivity/Bluetooth
 %description ipsp
 Bluetooth agent binary compiled for IPSP(Internet Protocol Support Profile)
 
+%package tool
+Summary:       Test Application for HF
+
+%description tool
+Test Application for HF
+
 %prep
 %setup -q
 cp %{SOURCE1001} .
@@ -148,6 +155,9 @@ find . -name '*.gcno' -exec cp '{}' gcov-obj ';'
 rm -rf %{buildroot}
 %make_install
 
+mkdir -p %{buildroot}%{_libdir}/systemd/system/
+mkdir -p %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/
+
 # This usage of profile macro does NOT conflict 4.0 configurability.
 #%if "%{?profile}" != "mobile" && "%{?profile}" != "tv"
 # Original: wearable, ivi. Added: common, "undefined"
@@ -176,6 +186,9 @@ pushd unittest
 popd
 %endif
 
+install -D -m 0644 packaging/bluetooth-hf-agent.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hf-agent.service
+ln -s ../bluetooth-hf-agent.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hf-agent.service
+
 %files
 %manifest %{name}.manifest
 %license LICENSE
@@ -204,6 +217,8 @@ popd
 %{_unitdir}/bluetooth-hf-agent.service
 #%exclude %{_unitdir}/bluetooth-map-agent.service
 #%exclude %{_unitdir}/bluetooth-pbap-agent.service
+%{_libdir}/systemd/system/bluetooth-hf-agent.service
+%{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hf-agent.service
 
 %files map
 %manifest %{name}.manifest
@@ -235,3 +250,6 @@ popd
 %{_bindir}/bluetooth-ipsp-agent
 %{_datadir}/dbus-1/system-services/org.bluez.ipsp_agent.service
 %{_sysconfdir}/dbus-1/system.d/bluetooth-ipsp-agent.conf
+
+%files tool
+%{_bindir}/hf-test