Fix invalid path in aarch64
[platform/core/connectivity/bluetooth-agent.git] / packaging / bluetooth-agent.spec
index 81da085..70bc363 100644 (file)
@@ -155,8 +155,7 @@ find . -name '*.gcno' -exec cp '{}' gcov-obj ';'
 rm -rf %{buildroot}
 %make_install
 
-mkdir -p %{buildroot}%{_libdir}/systemd/system/
-mkdir -p %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/
+mkdir -p %{buildroot}%{_unitdir}/multi-user.target.wants/
 
 # This usage of profile macro does NOT conflict 4.0 configurability.
 #%if "%{?profile}" != "mobile" && "%{?profile}" != "tv"
@@ -186,8 +185,8 @@ pushd unittest
 popd
 %endif
 
-install -D -m 0644 packaging/bluetooth-hf-agent.service %{buildroot}%{_libdir}/systemd/system/bluetooth-hf-agent.service
-ln -s ../bluetooth-hf-agent.service %{buildroot}%{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hf-agent.service
+install -D -m 0644 packaging/bluetooth-hf-agent.service %{buildroot}%{_unitdir}/bluetooth-hf-agent.service
+ln -s ../bluetooth-hf-agent.service %{buildroot}%{_unitdir}/multi-user.target.wants/bluetooth-hf-agent.service
 
 %files
 %manifest %{name}.manifest
@@ -215,10 +214,9 @@ ln -s ../bluetooth-hf-agent.service %{buildroot}%{_libdir}/systemd/system/multi-
 %{_datadir}/dbus-1/system-services/org.bluez.hf_agent.service
 %{_sysconfdir}/dbus-1/system.d/bluetooth-hf-agent.conf
 %{_unitdir}/bluetooth-hf-agent.service
+%{_unitdir}/multi-user.target.wants/bluetooth-hf-agent.service
 #%exclude %{_unitdir}/bluetooth-map-agent.service
 #%exclude %{_unitdir}/bluetooth-pbap-agent.service
-%{_libdir}/systemd/system/bluetooth-hf-agent.service
-%{_libdir}/systemd/system/multi-user.target.wants/bluetooth-hf-agent.service
 
 %files map
 %manifest %{name}.manifest