fix build error on building gcov mode
[platform/core/connectivity/bluetooth-agent.git] / ipsp-agent / CMakeLists.txt
index 7735666..1943edb 100644 (file)
@@ -41,7 +41,7 @@ TARGET_LINK_LIBRARIES(${PROJECT_NAME} ${pkgs_ipsp_agent_LDFLAGS} -L${CMAKE_CURRE
 
 IF (BUILD_GTESTS)
 # -fvisibility option should be "default" to call internal functions
-SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${EXTRA_CFLAGS} -fvisibility=default -fPIC -Werror -Wno-deprecated-declarations -fprofile-arcs -ftest-coverage")
+SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${EXTRA_CFLAGS} -fvisibility=default -Werror -Wno-deprecated-declarations")
 
 ADD_LIBRARY(ipsp-agent SHARED ${SRCS})
 SET_TARGET_PROPERTIES(ipsp-agent
@@ -49,9 +49,9 @@ SET_TARGET_PROPERTIES(ipsp-agent
         SOVERSION 0.1.0
         CLEAN_DIRECT_OUTPUT 1)
 
-TARGET_LINK_LIBRARIES(ipsp-agent ${pkgs_ipsp_agent_LDFLAGS} -lgcov)
+TARGET_LINK_LIBRARIES(ipsp-agent ${pkgs_ipsp_agent_LDFLAGS})
 
-INSTALL(TARGETS ipsp-agent DESTINATION lib COMPONENT RuntimeLibraries)
+INSTALL(TARGETS ipsp-agent DESTINATION ${LIB_INSTALL_DIR} COMPONENT RuntimeLibraries)
 ENDIF (BUILD_GTESTS)
 
 INSTALL(TARGETS ${PROJECT_NAME} DESTINATION bin)