Add the dbus privilege check logic for platform APIs
[platform/core/connectivity/bluetooth-agent.git] / hf-agent / CMakeLists.txt
index da878f5..1ee2094 100644 (file)
@@ -25,3 +25,6 @@ TARGET_LINK_LIBRARIES(${PROJECT_NAME} ${pkgs_hf_agent_LDFLAGS})
 INSTALL(TARGETS ${PROJECT_NAME} DESTINATION bin)
 INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/org.bluez.hf_agent.service
                DESTINATION share/dbus-1/system-services)
+
+CONFIGURE_FILE(${CMAKE_CURRENT_SOURCE_DIR}/bluetooth-hf-agent.conf.in ${CMAKE_CURRENT_SOURCE_DIR}/bluetooth-hf-agent.conf)
+INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/bluetooth-hf-agent.conf DESTINATION /etc/dbus-1/system.d)