Add systemd service
[platform/core/connectivity/asp-manager.git] / packaging / asp-manager.spec
index f45ec6e..851cd21 100755 (executable)
@@ -1,12 +1,13 @@
 Name:       asp-manager
 Summary:    ASP(application service platform) manager
-Version:    0.0.33
+Version:    0.0.34
 Release:    1
 Group:      Network & Connectivity/Other
 License:    Apache-2.0
 Source0:    %{name}-%{version}.tar.gz
 Source1:    dbus-asp-manager.conf
 Source2:    net.asp.service
+Source3:    asp-manager.service
 
 BuildRequires:  cmake
 BuildRequires:  pkgconfig(glib-2.0)
@@ -34,8 +35,10 @@ An application service platform manager to manage services and sessions
 chmod 644 %{SOURCE0}
 chmod 644 %{SOURCE1}
 chmod 644 %{SOURCE2}
+chmod 644 %{SOURCE3}
 cp -a %{SOURCE1} ./asp-manager.conf
 cp -a %{SOURCE2} .
+cp -a %{SOURCE3} .
 
 %build
 
@@ -56,6 +59,8 @@ rm -rf %{buildroot}
 
 mkdir -p %{buildroot}%{_datadir}/dbus-1/system-services/
 cp net.asp.service %{buildroot}%{_datadir}/dbus-1/system-services/
+mkdir -p %{buildroot}%{_libdir}/systemd/system/
+cp asp-manager.service %{buildroot}%{_libdir}/systemd/system/
 
 #DBus DAC (net-config.manifest enables DBus SMACK)
 mkdir -p %{buildroot}%{_sysconfdir}/dbus-1/system.d
@@ -73,3 +78,4 @@ cp asp-manager.conf %{buildroot}%{_sysconfdir}/dbus-1/system.d/asp-manager.conf
 #DBus DAC
 %attr(644,root,root) %{_sysconfdir}/dbus-1/system.d/asp-manager.conf
 %attr(644,root,root) %{_datadir}/dbus-1/system-services/net.asp.service
+%attr(644,root,root) %{_libdir}/systemd/system/asp-manager.service