Add unit test for sending and recieving notifications
[platform/core/appfw/notification-service.git] / packaging / notification-service.spec
index 4028a2c..d2e8b4d 100644 (file)
@@ -15,6 +15,12 @@ Headless notification service that collects incoming notifications from the
 the platform, maintains a database of active notifications, and broadcast updates
 to all listeners.
 
+%package test
+Summary: Test clients for %{name}
+Group:   Application Framework/Notifications
+%description test
+This package provides unit test used in the development of the notification service.
+
 %prep
 %setup -q -n %{name}-%{version}
 
@@ -34,3 +40,8 @@ rm -rf %{buildroot}
 %{_libdir}/systemd/system/notifications.service
 %{_libdir}/systemd/system/notifications.socket
 %{_libdir}/systemd/system/sockets.target.wants/notifications.socket
+
+%files test
+%defattr(-,root,root,-)
+%{_bindir}/sample-display-client
+%{_bindir}/send-notification