Use new Bluetooth-frwk bt_agent_reply_sync() APIs
[platform/core/appfw/notification-service.git] / packaging / notification-service.spec
index 33aad4f..062cccc 100644 (file)
@@ -1,3 +1,5 @@
+%bcond_with wayland
+
 Name:       notification-service
 Summary:    Simple notification service
 Version:    0.0.3
@@ -12,8 +14,12 @@ BuildRequires: pkgconfig(notification)
 BuildRequires: pkgconfig(notification-service)
 BuildRequires: pkgconfig(dbus-1)
 BuildRequires: pkgconfig(dbus-glib-1)
-BuildRequires: pkgconfig(bluetooth-api)
+BuildRequires: pkgconfig(dlog)
+BuildRequires: bluetooth-frwk-devel
 BuildRequires: pkgconfig(bundle)
+%if %{with wayland}
+BuildRequires: pkgconfig(libwlmessage)
+%endif
 %{?systemd_requires}
 
 %description
@@ -31,12 +37,17 @@ This package provides unit test used in the development of the notification serv
 %setup -q -n %{name}-%{version}
 
 %build
+%if %{with wayland}
+%autogen --enable-wayland
+%else
 %autogen
+%endif
 make %{?_smp_mflags}
 
 %install
 %make_install
 %install_service graphical.target.wants notifications.service
+%install_service graphical.target.wants notifications_display.service
 
 %post
 %systemd_post notifications.service
@@ -50,8 +61,11 @@ make %{?_smp_mflags}
 %files
 %defattr(-,root,root,-)
 %{_bindir}/notification-service
+%{_bindir}/notification-display-service
 %{_unitdir}/notifications.service
+%{_unitdir}/notifications_display.service
 %{_unitdir}/graphical.target.wants/notifications.service
+%{_unitdir}/graphical.target.wants/notifications_display.service
 
 %files test
 %defattr(-,root,root,-)