Use new Bluetooth-frwk bt_agent_reply_sync() APIs
[platform/core/appfw/notification-service.git] / packaging / notification-service.spec
1 %bcond_with wayland
2
3 Name:       notification-service
4 Summary:    Simple notification service
5 Version:    0.0.3
6 Release:    1
7 Group:      Application Framework/Notifications
8 License:    Flora
9 Source0:    %{name}-%{version}.tar.bz2
10 BuildRequires: pkgconfig(eina)
11 BuildRequires: pkgconfig(ecore)
12 BuildRequires: pkgconfig(com-core)
13 BuildRequires: pkgconfig(notification)
14 BuildRequires: pkgconfig(notification-service)
15 BuildRequires: pkgconfig(dbus-1)
16 BuildRequires: pkgconfig(dbus-glib-1)
17 BuildRequires: pkgconfig(dlog)
18 BuildRequires: bluetooth-frwk-devel
19 BuildRequires: pkgconfig(bundle)
20 %if %{with wayland}
21 BuildRequires: pkgconfig(libwlmessage)
22 %endif
23 %{?systemd_requires}
24
25 %description
26 Headless notification service that collects incoming notifications from the
27 the platform, maintains a database of active notifications, and broadcast updates
28 to all listeners.
29
30 %package test
31 Summary: Test clients for %{name}
32 Group:   Application Framework/Notifications
33 %description test
34 This package provides unit test used in the development of the notification service.
35
36 %prep
37 %setup -q -n %{name}-%{version}
38
39 %build
40 %if %{with wayland}
41 %autogen --enable-wayland
42 %else
43 %autogen
44 %endif
45 make %{?_smp_mflags}
46
47 %install
48 %make_install
49 %install_service graphical.target.wants notifications.service
50 %install_service graphical.target.wants notifications_display.service
51
52 %post
53 %systemd_post notifications.service
54
55 %preun
56 %systemd_preun notifications.service
57
58 %postun
59 %systemd_postun notifications.service
60
61 %files
62 %defattr(-,root,root,-)
63 %{_bindir}/notification-service
64 %{_bindir}/notification-display-service
65 %{_unitdir}/notifications.service
66 %{_unitdir}/notifications_display.service
67 %{_unitdir}/graphical.target.wants/notifications.service
68 %{_unitdir}/graphical.target.wants/notifications_display.service
69
70 %files test
71 %defattr(-,root,root,-)
72 %{_bindir}/sample-display-client
73 %{_bindir}/send-notification
74 %{_bindir}/bluetooth_notification_client