Merge branch 'tizen_2.2' into tizen
[platform/core/appfw/heynoti.git] / packaging / heynoti.spec
index 891f7d9..d9135ee 100644 (file)
@@ -1,20 +1,21 @@
-#
-
 Name:           heynoti
 Version:        0.0.2
-Release:        41
-License:        Apache License, Version 2.0
+Release:        0
+License:        Apache-2.0
 Summary:        HEY (ligHt Easy speedy) notification library
 Group:          System/Libraries
 Source0:        %{name}-%{version}.tar.gz
+Source1001:     heynoti.manifest
 
 BuildRequires:  cmake
 BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(ecore)
 BuildRequires:  pkgconfig(glib-2.0)
+BuildRequires:  pkgconfig(libtzplatform-config)
 
 %description
-lightweight notification library, service APIs
+HEY (ligHt Easy speedy) notification library is a lightweight
+notification library with service APIs.
 
 %package devel
 Summary:        Notification library
@@ -23,10 +24,13 @@ Requires:       %{name} = %{version}
 Requires:       heynoti
 
 %description devel
-heynoti API (devel)
+Development files for HEY (ligHt Easy speedy) notification library. HEY
+is a lightweight notification library with service APIs.
+
 
 %prep
 %setup -q
+cp %{SOURCE1001} .
 
 
 %build
@@ -37,9 +41,10 @@ make %{?_smp_mflags}
 
 %install
 %make_install
+
+mkdir -p %{buildroot}%{TZ_SYS_SHARE}/noti
 mkdir -p %{buildroot}/usr/share/license
 install LICENSE %{buildroot}/usr/share/license/%{name}
-mkdir -p %{buildroot}/opt/share/noti
 
 %post -p /sbin/ldconfig
 
@@ -47,16 +52,17 @@ mkdir -p %{buildroot}/opt/share/noti
 
 
 %files
-%manifest heynoti.manifest
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
 %{_libdir}/libheynoti.so.0
 %{_libdir}/libheynoti.so.0.0.2
 %{_bindir}/heynotitool
-%attr(1755,root,root) /opt/share/noti
+%attr(1755,root,root) %{TZ_SYS_SHARE}/noti
 /usr/share/license/%{name}
 
 
 %files devel
+%manifest %{name}.manifest
 %defattr(-,root,root,-)
 %{_includedir}/heynoti/SLP_Heynoti_PG.h
 %{_includedir}/heynoti/heynoti.h