Remove Profile Build Dependency: Do it at runtime
[platform/core/appfw/app-core.git] / packaging / app-core.spec
index d5f2513..fa84c6a 100644 (file)
@@ -34,6 +34,7 @@ BuildRequires:  pkgconfig(glib-2.0)
 BuildRequires:  pkgconfig(pkgmgr-info)
 BuildRequires:  pkgconfig(ttrace)
 BuildRequires:  cmake
+BuildRequires:  pkgconfig(capi-system-info)
 
 %description
 SLP common application basic
@@ -92,18 +93,6 @@ Group:      Development/Libraries
 %description template
 Application basics template
 
-%if "%{?profile}" == "wearable"
-%define appfw_feature_background_management 1
-%else
-%if "%{?profile}" == "mobile"
-%define appfw_feature_background_management 1
-%else
-%if "%{?profile}" == "tv"
-%define appfw_feature_background_management 0
-%endif
-%endif
-%endif
-
 %prep
 %setup -q
 cp %{SOURCE1001} .
@@ -115,14 +104,10 @@ _WITH_WAYLAND=ON
 %if %{with x}
 _WITH_X11=ON
 %endif
-%if 0%{?appfw_feature_background_management}
-_APPFW_FEATURE_BACKGROUND_MANAGEMENT=ON
-%endif
 
 %cmake . \
        -D_WITH_WAYLAND:BOOL=${_WITH_WAYLAND} \
        -D_WITH_X11:BOOL=${_WITH_X11} \
-       -D_APPFW_FEATURE_BACKGROUND_MANAGEMENT:BOOL=${_APPFW_FEATURE_BACKGROUND_MANAGEMENT} \
        -DENABLE_GTK=OFF
 
 make %{?_smp_mflags}