Release version 1.14.1
[platform/core/appfw/app-core.git] / packaging / app-core.spec
index 0eebdc5..bbd4897 100644 (file)
@@ -1,11 +1,11 @@
 Name:           app-core
 Summary:        Application basic
-Version:        1.9.2
+Version:        1.14.1
 Release:        0
 Group:          Application Framework/Libraries
 License:        Apache-2.0
 Source0:        app-core-%{version}.tar.gz
-BuildRequires:  pkgconfig(ecore-wayland)
+BuildRequires:  pkgconfig(ecore-wl2)
 BuildRequires:  pkgconfig(wayland-client)
 BuildRequires:  pkgconfig(tizen-extension-client)
 BuildRequires:  pkgconfig(wayland-tbm-client)
@@ -119,6 +119,7 @@ Application basics template
 cp %{SOURCE1001} .
 
 %build
+export CFLAGS+=" -DEFL_BETA_API_SUPPORT "
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
 %cmake . \
        -DENABLE_GTK=OFF \
@@ -184,6 +185,8 @@ rm -rf %{buildroot}
 %{_libdir}/pkgconfig/appcore-common.pc
 %{_includedir}/appcore/appcore-common.h
 %{_includedir}/appcore/appcore_base.h
+%{_includedir}/appcore/appcore_watchdog.h
+%{_includedir}/appcore/appcore_base_control.h
 
 %files ui
 %manifest %{name}.manifest