Support handling of each app-control ID
[platform/core/appfw/app-core.git] / packaging / app-core.spec
index 9415865..5770ce1 100644 (file)
@@ -1,11 +1,11 @@
 Name:           app-core
 Summary:        Application basic
-Version:        1.8.3
+Version:        1.12.5
 Release:        0
 Group:          Application Framework/Libraries
 License:        Apache-2.0
 Source0:        app-core-%{version}.tar.gz
-BuildRequires:  pkgconfig(ecore-wayland)
+BuildRequires:  pkgconfig(ecore-wl2)
 BuildRequires:  pkgconfig(wayland-client)
 BuildRequires:  pkgconfig(tizen-extension-client)
 BuildRequires:  pkgconfig(wayland-tbm-client)
@@ -14,7 +14,7 @@ BuildRequires:  pkgconfig(gio-2.0)
 BuildRequires:  pkgconfig(sensor)
 BuildRequires:  pkgconfig(vconf)
 BuildRequires:  pkgconfig(aul)
-BuildRequires:  pkgconfig(rua)
+BuildRequires:  pkgconfig(bundle)
 BuildRequires:  pkgconfig(dlog)
 BuildRequires:  pkgconfig(elementary)
 BuildRequires:  pkgconfig(ecore)
@@ -43,7 +43,7 @@ Application basic EFL
 Summary:    App basic EFL (devel)
 Group:      Development/Libraries
 Requires:   %{name}-efl = %{version}-%{release}
-Requires:   %{name}-common-devel = %{version}-%{release}
+Requires:   %{name}-ui-devel = %{version}-%{release}
 
 %description efl-devel
 Application basic EFL (devel)
@@ -88,6 +88,24 @@ Requires:   pkgconfig(aul)
 %description common-devel
 Application basics common (devel)
 
+%package ui
+Summary:    App basic UI
+Group:      Development/Libraries
+Requires(post): /sbin/ldconfig
+Requires(postun): /sbin/ldconfig
+
+%description ui
+Application basic UI
+
+%package ui-devel
+Summary:    App basic UI (devel)
+Group:      Development/Libraries
+Requires:   %{name}-ui = %{version}-%{release}
+Requires:   %{name}-common-devel = %{version}-%{release}
+
+%description ui-devel
+Application basic EFL (devel)
+
 
 %package template
 Summary:    App basics template
@@ -101,6 +119,7 @@ Application basics template
 cp %{SOURCE1001} .
 
 %build
+export CFLAGS+=" -DEFL_BETA_API_SUPPORT "
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
 %cmake . \
        -DENABLE_GTK=OFF \
@@ -127,6 +146,10 @@ rm -rf %{buildroot}
 
 %postun -n app-core-common -p /sbin/ldconfig
 
+%post -n app-core-ui -p /sbin/ldconfig
+
+%postun -n app-core-ui -p /sbin/ldconfig
+
 
 %files efl
 %manifest %{name}.manifest
@@ -136,7 +159,7 @@ rm -rf %{buildroot}
 %files efl-devel
 %manifest %{name}.manifest
 %{_includedir}/appcore/appcore-efl.h
-%{_includedir}/appcore/appcore_ui_base.h
+%{_includedir}/appcore/appcore_efl_base.h
 %{_libdir}/libappcore-efl.so
 %{_libdir}/pkgconfig/appcore-efl.pc
 
@@ -162,4 +185,16 @@ rm -rf %{buildroot}
 %{_libdir}/pkgconfig/appcore-common.pc
 %{_includedir}/appcore/appcore-common.h
 %{_includedir}/appcore/appcore_base.h
+%{_includedir}/appcore/appcore_watchdog.h
+%{_includedir}/appcore/appcore_base_control.h
 
+%files ui
+%manifest %{name}.manifest
+%{_libdir}/libappcore-ui.so.*
+%license LICENSE
+
+%files ui-devel
+%manifest %{name}.manifest
+%{_includedir}/appcore/appcore_ui_base.h
+%{_libdir}/libappcore-ui.so
+%{_libdir}/pkgconfig/appcore-ui.pc