Fix coverage script
[platform/core/api/system-settings.git] / packaging / capi-system-system-settings.spec
index 3e3d404..808be7d 100644 (file)
@@ -133,6 +133,12 @@ cat << EOF > run-unittest.sh
 #!/bin/sh
 setup() {
        echo "setup start"
+       if [ -d "conf_example" ]; then
+               rm -rf ./conf_example
+               rm -rf ./tests
+       fi
+       ln -s /usr/bin/sys-settings/tests ./tests
+       ln -s /usr/bin/sys-settings/conf_example ./conf_example
 }
 
 test_main() {
@@ -144,6 +150,8 @@ test_main() {
 
 teardown() {
        echo "teardown start"
+       rm -rf ./tests
+       rm -rf ./conf_example
 }
 
 main() {
@@ -193,6 +201,7 @@ genhtml %{name}.info -o out --legend --show-details
 %files unittests
 %manifest %{name}.manifest
 %{sys_setting_test_dir}/*
+%{_libdir}/libsys-settings-mock.so
 %{_bindir}/tizen-unittests/%{name}/run-unittest.sh
 %license LICENSE.APLv2