Make some macros consistent
[platform/core/api/system-info.git] / packaging / capi-system-info.spec
index 1f5d784..d3e316e 100644 (file)
@@ -1,5 +1,3 @@
-%define config_file_path %{_sysconfdir}/config/model-config.xml
-
 Name:           capi-system-info
 Version:        0.5
 Release:        1
@@ -37,20 +35,22 @@ cp %{SOURCE1001} .
 %define info_file_path /etc/info.ini
 %define sysinfo_shared_path %{TZ_SYS_ETC}/sysinfo
 %define tizen_id_path %{sysinfo_shared_path}/tizenid
-%define db_path %{TZ_SYS_RO_ETC}/system_info_db
-%define model_config_path /opt/system/model-config
-%define db_runtime_path %{model_config_path}/system_info_db
+
+%define model_config_ro_path %{_sysconfdir}/config/model-config.xml
+%define db_ro_path %{TZ_SYS_RO_ETC}/system_info_db
+%define model_config_rw_dir /opt/system/model-config
+%define db_rw_path %{model_config_rw_dir}/system_info_db
 
 %build
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
 
-%cmake . -DCONFIG_FILE_PATH=%{config_file_path} \
+%cmake . -DMODEL_CONFIG_RO_PATH=%{model_config_ro_path} \
          -DINFO_FILE_PATH=%{info_file_path} \
             -DMAJORVER=${MAJORVER} \
             -DFULLVER=%{version} \
             -DTIZEN_ID_PATH=%{tizen_id_path} \
-            -DDB_PATH=%{db_path} \
-            -DDB_RUNTIME_PATH=%{db_runtime_path}
+            -DDB_RO_PATH=%{db_ro_path} \
+            -DDB_RW_PATH=%{db_rw_path}
 
 %__make %{?_smp_mflags}
 
@@ -62,11 +62,11 @@ cp -f script/make_info_file.sh %{buildroot}/etc/make_info_file.sh
 %install_service sysinit.target.wants tizenid.service
 
 mkdir -p %{buildroot}/%{sysinfo_shared_path}
-mkdir -p %{buildroot}/%{model_config_path}
+mkdir -p %{buildroot}/%{model_config_rw_dir}
 
 %posttrans
 /usr/bin/chsmack -a "System::Shared" -t %{sysinfo_shared_path}
-/usr/bin/chsmack -a "System::Shared" -t %{model_config_path}
+/usr/bin/chsmack -a "System::Shared" -t %{model_config_rw_dir}
 /usr/bin/system_info_init_db
 /sbin/ldconfig
 
@@ -79,7 +79,7 @@ mkdir -p %{buildroot}/%{model_config_path}
 %attr(0744,root,-) /etc/make_info_file.sh
 %{_bindir}/system_info_init_db
 
-%attr(0775,root,system_share) %dir %{model_config_path}
+%attr(0775,root,system_share) %dir %{model_config_rw_dir}
 #tizenid
 %attr(0775,root,system_share) %dir %{sysinfo_shared_path}
 %{_bindir}/tizen_id