Implement APIs for IPv6 and DNS configuration
[platform/core/api/connection.git] / packaging / capi-network-connection.spec
index 4f6cd24..8402876 100755 (executable)
@@ -1,6 +1,6 @@
 Name:          capi-network-connection
 Summary:       Network Connection library in TIZEN C API
-Version:       1.0.82
+Version:       1.0.97
 Release:       1
 Group:         System/Network
 License:       Apache-2.0
@@ -31,25 +31,13 @@ Network Connection library in Tizen C API (Development)
 
 
 %build
-export CFLAGS+=' -Wno-unused-local-typedefs -fprofile-arcs -ftest-coverage'
-export LDFLAGS+=' -lgcov'
+export CFLAGS+=' -Wno-unused-local-typedefs'
 MAJORVER=`echo %{version} | awk 'BEGIN {FS="."}{print $1}'`
 cmake -DCMAKE_INSTALL_PREFIX=/usr -DFULLVER=%{version} -DMAJORVER=${MAJORVER} \
        -DLIB_PATH=%{_lib} \
 %if 0%{?model_build_feature_network_dsds} == 1
        -DTIZEN_DUALSIM_ENABLE=1 \
 %endif
-%if "%{profile}" == "wearable"
-       -DTIZEN_WEARABLE=1 \
-%else
-%if "%{profile}" == "mobile"
-       -DTIZEN_MOBILE=1 \
-%else
-%if "%{profile}" == "tv"
-       -DTIZEN_TV=1 \
-%endif
-%endif
-%endif
        .
 
 make %{?_smp_mflags}