move __IsReady function into the critical section
[platform/core/api/audio-io.git] / test / CMakeLists.txt
index 67cedc2..9505dff 100644 (file)
@@ -13,7 +13,7 @@ FOREACH(src ${sources})
     GET_FILENAME_COMPONENT(src_name ${src} NAME_WE)
     MESSAGE("${src_name}")
     ADD_EXECUTABLE(${src_name} ${src})
-    TARGET_LINK_LIBRARIES(${src_name} ${fw_name} ${${fw_test}_LDFLAGS} -lm)
+    TARGET_LINK_LIBRARIES(${src_name} ${fw_name} ${${fw_test}_LDFLAGS} -lm -pthread)
 ENDFOREACH()
 
 INSTALL(TARGETS audio_io_test DESTINATION bin)