upload tizen1.0 source
[kernel/linux-2.6.36.git] / packaging / linux-2.6.36.spec
1 Name:           linux  
2 Summary:        The Linux Kernel v2.6.36
3 Version:        2.6.36
4 Release:        1  
5 License:        GPL
6 Group:          System/Kernel 
7 URL:            http://www.kernel.org
8 Source:         %{name}-%{version}.tar.gz 
9
10 BuildRequires:  cpio 
11 BuildRequires:  lzma 
12 BuildRequires:  python 
13 BuildRequires:  binutils-devel
14 BuildRequires:  lzop
15 BuildRequires:  u-boot-tools
16 BuildRequires:  module-init-tools
17
18 %description  
19 The Linux Kernel, the operating system core itself
20   
21 %package -n %{name}-source-%{version}
22 License:        TO_BE_FILLED  
23 Summary:        Linux kernel source for version 2.6.36
24 Group:          TO_BE_FILLED/TO_BE_FILLED
25   
26 %description -n %{name}-source-%{version}
27  Linux kernel source for version 2.6.36 
28  This package provides source code for the Linux kernel version 2.6.36.
29  This source closely tracks official Linux kernel releases.  Debian's
30  modifications to that source consist of security fixes, bug fixes, and
31  features that have already been (or are believed to be) accepted by the
32  upstream maintainers.
33
34 %package -n %{name}-tools-%{version}
35 License:        TO_BE_FILLED  
36 Summary:        Performance analysis tools for Linux 2.6.36
37 Group:          TO_BE_FILLED/TO_BE_FILLED 
38   
39 %description -n %{name}-tools-%{version}
40  This package contains the 'perf' performance analysis tools for Linux
41  kernel version 2.6.36.
42  .
43  The linux-base package contains a 'perf' command which will invoke the
44  appropriate version for the running kernel.
45
46 %package -n %{name}-doc-%{version}
47 License:        TO_BE_FILLED  
48 Summary:        Linux kernel specific documentation for version 2.6.36
49 Group:          TO_BE_FILLED/TO_BE_FILLED 
50   
51 %description -n %{name}-doc-%{version}
52  This package provides the various README files and HTML documentation for
53  the Linux kernel version 2.6.36.  Plenty of information, including the
54  descriptions of various kernel subsystems, filesystems, driver-specific
55  notes and the like.  Consult the file
56  /usr/share/doc/linux-doc-2.6.36/Documentation/00-INDEX for the detailed
57  description of the contents.
58
59 %package -n %{name}-manual-%{version}
60 License:        TO_BE_FILLED  
61 Summary:        Linux kernel API manual pages for version 2.6.36
62 Group:          TO_BE_FILLED/TO_BE_FILLED 
63   
64 %description -n %{name}-manual-%{version}
65  This package provides the Kernel Hacker's Guide in the form of manual
66  pages, describing the kernel API functions.  They are installed into
67  section 9 of the manual.
68  .
69  As the files containing manual pages for different kernel versions are
70  installed in the same location, only one linux-manual package may be
71  installed at a time.  The linux-doc package containing the documentation
72  in other formats is free from such restriction.
73
74 %package -n %{name}-%{version}-firmware-linux-free
75 License:        TO_BE_FILLED  
76 Summary:        Binary firmware for various drivers in the Linux kernel
77 Group:          TO_BE_FILLED/TO_BE_FILLED 
78   
79 %description -n %{name}-%{version}-firmware-linux-free
80  This package contains firmware which was previously included in the Linux
81  kernel and which is compliant with the Debian Free Software Guidelines.
82  .
83  Most firmware previously included in the Linux kernel is non-free and has
84  been moved to the firmware-linux-nonfree package.
85
86 %package -n %{name}-headers
87 License:        TO_BE_FILLED  
88 Summary:        Linux support headers for userspace development
89 Group:          TO_BE_FILLED/TO_BE_FILLED 
90   
91 %description -n %{name}-headers
92  This package provides userspaces headers from the Linux kernel.  These
93  headers are used by the installed headers for GNU glibc and other system
94  libraries.
95
96
97 %prep
98 %setup -q
99
100 %build
101 make u1_defconfig
102 make uImage %{?jobs:-j%jobs}
103 make modules
104
105 %install  
106 mkdir -p %{buildroot}/boot
107 mkdir -p %{buildroot}/lib/modules
108 mkdir -p %{buildroot}/usr
109 make modules_install INSTALL_MOD_PATH=%{buildroot} 
110 make headers_install INSTALL_HDR_PATH=%{buildroot}/usr
111 find %{buildroot}/usr/ -name ..install.cmd -exec rm "{}" \;
112 find %{buildroot}/usr/ -name .install -exec rm "{}" \;
113 install -m 755 arch/arm/boot/uImage %{buildroot}/boot/
114
115 %clean
116 rm -rf %{buildroot}
117
118 %files
119 %defattr (-, root, root)
120 /lib/modules/*
121 /boot/*
122
123 %files -n %{name}-headers
124 /usr/include/*