Update wrt-plugins-common_0.3.53
[framework/web/wrt-plugins-common.git] / src / standards / W3C / Widget / CMakeLists.txt
index 6444650..e6ab932 100755 (executable)
 #
 set(TARGET_NAME "wrt-plugins-w3c-widget-interface")
 
-pkg_search_module(webkit REQUIRED ewebkit>=0.1.0)
-pkg_search_module(wrt-plugin-api REQUIRED wrt-plugin-api>=0.7.0)
+pkg_search_module(webkit2 REQUIRED ewebkit2)
+pkg_search_module(plugin-types REQUIRED wrt-plugins-types)
 
 set(SRCS
   ${SRCS_COMMONS}
   JSWidget.cpp
   JSPreferences.cpp
-  JSStorageEvent.cpp
   plugin_initializer.cpp
-  IFrameSupport.cpp
-  AddEventListenerSupport.cpp
+  plugin_config.cpp
 )
 
-IF(W3C_TEST)
-set(SRCS
-  ${SRCS}
-  JSTest.cpp
-  Test.cpp
-)
-ENDIF(W3C_TEST)
-
-include_directories( ${API_WIDGET_PATH}
+include_directories(
+  ${API_WIDGET_PATH}
+  ${webkit2_INCLUDE_DIRS}
+  ${plugin-types_INCLUDE_DIRS}
 #  ${API_STORAGE_EVENT_PATH}
 #  ${API_LOCALSTORAGE_PATH}
-  ${webkit_INCLUDE_DIRS}
-  ${wrt-plugin-api_INCLUDE_DIRS}
 )
 
 add_library(${TARGET_NAME} SHARED ${SRCS})
@@ -47,10 +38,10 @@ target_link_libraries(${TARGET_NAME}
   ${LIBS_COMMON}
   ${TARGET_COMMONS}
   ${TARGET_COMMONS_JAVASCRIPT}
+  ${TARGET_JS_OVERLAY}
   wrt-plugins-widget
   wrt-plugins-localstorage
   wrt-plugins-storageevent
 )
 
 INSTALL(TARGETS ${TARGET_NAME} LIBRARY DESTINATION ${STANDARD_FILE_DESTINATION}/w3c-widget-interface)
-INSTALL(FILES ${CMAKE_CURRENT_SOURCE_DIR}/config.xml DESTINATION ${STANDARD_FILE_DESTINATION}/w3c-widget-interface)